Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#! /bin/sh /usr/share/dpatch/dpatch-run
## 20_build_fixes.dpatch by Magnus Holmgren <magnus@kibibyte.se>
##
## DP: Fix minor errors in makefile and configuration script

@DPATCH@

--- pmk-0.10.1.orig/Makefile.pmk
+++ pmk-0.10.1/Makefile.pmk
@@ -52,7 +52,7 @@
 #
 # list of generated files
 #
-GEN_FILES=     Makefile Makefile compat/config.h
+GEN_FILES=     Makefile tests/Makefile compat/config.h
 
 #
 # source dependency lists
--- pmk-0.10.1.orig/pmkcfg.sh
+++ pmk-0.10.1/pmkcfg.sh
@@ -406,7 +406,7 @@
        fi
        mkf_sed 'CONFDIR' '$(SYSCONFDIR)/pmk'
        mkf_sed 'SBINDIR' '$(PREFIX)/sbin'
-       mkf_sed 'DATADIR' '$(PREFIX)/share/$(PREMAKE)'
+       mkf_sed 'DATADIR' '$(PREFIX)/share/pmk'
 fi
 
 mkf_sed 'BINDIR' '$(PREFIX)/bin'