Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #! /bin/sh |
2 | # postinst script for pmk |
||
3 | # |
||
4 | # see: dh_installdeb(1) |
||
5 | |||
6 | conffile=/etc/pmk/pmk.conf |
||
7 | |||
8 | set -e |
||
9 | |||
10 | if [ -e /usr/share/debconf/confmodule ]; then |
||
11 | . /usr/share/debconf/confmodule |
||
12 | fi |
||
13 | |||
14 | case "$1" in |
||
15 | configure|reconfigure) |
||
16 | # Note that -s and -g are added by 25_pmksetup.dpatch; |
||
17 | # they are not documented in pmksetup(8). |
||
18 | tempfile=`mktemp -t pmksetup.XXXXXXXXXX` |
||
19 | if pmksetup -s -g \ |
||
20 | -u PREFIX=\"/usr\" \ |
||
21 | -u BIN_CC=\"/usr/bin/gcc\" \ |
||
22 | -u BIN_CXX=\"/usr/bin/g++\" \ |
||
23 | -u PATH_BIN=\"/usr/local/bin:/usr/bin:/bin\" \ |
||
24 | -u OS_ARCH=\"`dpkg --print-architecture`\" \ |
||
25 | 2> /dev/null > $tempfile; |
||
26 | then |
||
27 | ucf --three-way --debconf-ok $tempfile $conffile |
||
28 | rm -f $tempfile |
||
29 | ucfr pmk $conffile |
||
30 | else |
||
31 | rm -f $tempfile |
||
32 | exit 1 |
||
33 | fi |
||
34 | |||
35 | # Clean out any remains of this package from the Debconf database |
||
36 | if [ -e /usr/share/debconf/confmodule ]; then |
||
37 | db_purge |
||
38 | fi |
||
39 | ;; |
||
40 | |||
41 | abort-upgrade|abort-remove|abort-deconfigure) |
||
42 | ;; |
||
43 | |||
44 | *) |
||
45 | echo "postinst called with unknown argument \`$1'" >&2 |
||
46 | exit 1 |
||
47 | ;; |
||
48 | esac |
||
49 | |||
50 | # dh_installdeb will replace this with shell code automatically |
||
51 | # generated by other debhelper scripts. |
||
52 | |||
53 | #DEBHELPER# |
||
54 | |||
55 | exit 0 |