Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Blame | Compare with Previous | Last modification | View Log | RSS feed

--- prayer-1.0.18.orig/prayer/dirlist.c
+++ prayer-1.0.18/prayer/dirlist.c
@@ -172,7 +172,8 @@
 
     dl->next = NIL;
     dl->name = pool_strdup(callback.pool, name);
-    dl->isdir = (attributes & LATT_NOINFERIORS) ? NIL : T;
+    dl->isdir = (attributes & (LATT_NOINFERIORS | LATT_HASNOCHILDREN)) ?
+               NIL : T;
 
     /* Insertion sort algorithm */