Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 23 | Blame | Compare with Previous | Last modification | View Log | RSS feed

--- a/files/etc/prayer-accountd.cf
+++ b/files/etc/prayer-accountd.cf
@@ -8,6 +8,10 @@
 # Default accountd.cf file suitable for RedHat Linux only.
 # See distribution for some sample files for FreeBSD and Solaris
 
+accountd_port = 145
+
+authtype = pam
+
 msforward_name      = ".MSforward"
 forward_name        = ".forward"
 aliases_name        = "vacation.aliases"
--- a/files/Makefile
+++ b/files/Makefile
@@ -65,26 +65,29 @@ install-aconfig:
 
 install-motd:
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
-       etc/motd.html ${BROOT}${PREFIX}/etc
+       etc/motd.html ${BROOT}/etc/prayer
 
 install-welcome:
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
-       etc/welcome.html ${BROOT}${PREFIX}/etc
+       etc/welcome.html ${BROOT}/etc/prayer
 
 install:
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX}
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer
+
        PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \
        RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \
        RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \
        PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \
        PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \
        PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \
-       BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
+       BIN_DIR=$(BROOT)$(BIN_DIR) INSTALL=$(INSTALL) \
        ./install.sh
-       if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
+#      if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
        if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
        if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
-       if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
-       if [ ! -f $(BROOT)$(PREFIX)/etc/welcome.html ]; then $(MAKE) install-welcome; fi
+       if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi
+       if [ ! -f $(BROOT)/etc/prayer/welcome.html ]; then $(MAKE) install-welcome; fi
 
 redhat-install-init.d:
        install -D -o root -g root -m 755 \
--- a/files/install.sh
+++ b/files/install.sh
@@ -4,77 +4,6 @@
 
 PATH=/bin:/sbin/:/usr/bin:/usr/sbin
 
-error=0
-
-if [ "x$PREFIX" = "x" ]; then
-    echo 'PREFIX not defined'
-    error=1
-fi
-
-if [ "x$VAR_PREFIX" = "x" ]; then
-    echo 'VAR_PREFIX not defined'
-    error=1
-fi
-
-if [ "x$RO_USER" = "x" ]; then
-    echo 'RO_USER not defined'
-    error=1
-fi
-
-if [ "x$RO_GROUP" = "x" ]; then
-    echo 'RO_GROUP not defined'
-    error=1
-fi
-
-if [ "x$RW_USER" = "x" ]; then
-    echo 'RW_USER not defined'
-    error=1
-fi
-
-if [ "x$RW_GROUP" = "x" ]; then
-    echo 'RW_GROUP not defined'
-    error=1
-fi
-
-if [ "x$PUBLIC_DIR" = "x" ]; then
-    echo 'PUBLIC_DIR not defined'
-    error=1
-fi
-
-if [ "x$PRIVATE_DIR" = "x" ]; then
-    echo 'PRIVATE_DIR not defined'
-    error=1
-fi
-
-if [ "x$BIN_DIR" = "x" ]; then
-    echo 'BIN_DIR not defined'
-    error=1
-fi
-
-if [ $error != 0 ]; then
-    exit 1
-fi
-
-if [ ! -d ${VAR_PREFIX} -a `whoami` = "root" ]; then
-    ${INSTALL} -d -o ${RW_USER} -g ${RW_GROUP} -m ${PRIVATE_DIR} ${VAR_PREFIX}
-fi
-
-if [ ! -d ${PREFIX} ]; then
-    ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${PREFIX}
-fi
-
-if [ ! -d ${PREFIX}/etc ]; then
-    ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${PREFIX}/etc
-fi
-
-if [ ! -d ${PREFIX}/certs ]; then
-    ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PRIVATE_DIR} ${PREFIX}/certs
-fi
-
-if [ ! -d ${BIN_DIR} ]; then
-    ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BIN_DIR}
-fi
-
 for i in icons
 do
     if [ -d "${PREFIX}/${i}" ]; then
--- a/files/etc/prayer.cf.SRC
+++ b/files/etc/prayer.cf.SRC
@@ -20,7 +20,7 @@ var_prefix  = "__VAR_PREFIX__"
 # User ID to run as if we start off as root
 prayer_user           = "prayer"
 # Group ID to run as if we start off as root
-prayer_group          = "prayer"
+prayer_group          = "nogroup"
 
 # Run prayer as background process.
 #   TRUE => will return as soon as valid configuration is found.
@@ -428,10 +428,10 @@ bin_dir             = "__BIN_DIR__"
 
 # Various directories used by the running system
 # Logs stored in $log_dir
-log_dir             = "$var_prefix/logs"
+log_dir             = "/var/log/prayer"
 
 # $lock_dir used for interlocking between prayer processes
-lock_dir            = "$var_prefix/locks"
+lock_dir            = "/var/lock"
 
 # $socket_dir is location for unix domain sockets which connect frontend
 # to backend in proxy mode of operation.
@@ -439,7 +439,7 @@ socket_dir          = "$var_prefix/socke
 
 # Split socket directory into 64 subdirs keyed on first letter of sessionID
 # Code provides compatibility in both directions: can switch back and forward
-socket_split_dir    = TRUE
+socket_split_dir    = FALSE
 
 # Name of Unix domain socket (in $socket_dir) used for initial handshake
 # between prayer and prayer-session processes when a user logs in
@@ -450,10 +450,10 @@ ssl_session_dir     = "$var_prefix/ssl_s
 
 # Location for temporary files e.g; attachments and folders in transist
 # during upload and download operation. Core files also end up here
-tmp_dir             = "$var_prefix/tmp"
+tmp_dir             = "/tmp"
 
 # Location for PID files for prayer and prayer-session master processes.
-pid_dir             = "$var_prefix/pid"
+pid_dir             = "$var_prefix"
 
 # Interface to Hermes finger database
 #lookup_rpasswd   = "/data/finger/rpasswd.cdb"
@@ -621,7 +621,7 @@ sent_mail_folder    = "sent-mail"
 # default_domain      = "<valid mail domain>"
 
 # Language for ispell.
-ispell_language     = "british"
+ispell_language     = "american"
 
 # Size of small and large compose windows
 small_cols          = 80