Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 44 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
12 magnus 1
--- a/files/etc/prayer-accountd.cf
2
+++ b/files/etc/prayer-accountd.cf
15 magnus 3
@@ -8,6 +8,10 @@
3 magnus 4
 # Default accountd.cf file suitable for RedHat Linux only.
5
 # See distribution for some sample files for FreeBSD and Solaris
6
 
7
+accountd_port = 145
8
+
15 magnus 9
+authtype = pam
10
+
3 magnus 11
 msforward_name      = ".MSforward"
12
 forward_name        = ".forward"
13
 aliases_name        = "vacation.aliases"
12 magnus 14
--- a/files/Makefile
15
+++ b/files/Makefile
44 magnus 16
@@ -65,26 +65,21 @@ install-aconfig:
3 magnus 17
 
18
 install-motd:
19
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
20
-       etc/motd.html ${BROOT}${PREFIX}/etc
23 magnus 21
+       etc/motd.html ${BROOT}/etc/prayer
3 magnus 22
 
23
 install-welcome:
24
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
25
-       etc/welcome.html ${BROOT}${PREFIX}/etc
23 magnus 26
+       etc/welcome.html ${BROOT}/etc/prayer
3 magnus 27
 
28
 install:
44 magnus 29
-       PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \
30
-       RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \
31
-       RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \
32
-       PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \
33
-       PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \
34
-       PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \
35
-       BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
36
-       ./install.sh
37
-       if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
23 magnus 38
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX}
39
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer
3 magnus 40
+
44 magnus 41
+       tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x
23 magnus 42
        if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
43
        if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
3 magnus 44
-       if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
45
-       if [ ! -f $(BROOT)$(PREFIX)/etc/welcome.html ]; then $(MAKE) install-welcome; fi
23 magnus 46
+       if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi
47
+       if [ ! -f $(BROOT)/etc/prayer/welcome.html ]; then $(MAKE) install-welcome; fi
3 magnus 48
 
49
 redhat-install-init.d:
50
        install -D -o root -g root -m 755 \
12 magnus 51
--- a/files/etc/prayer.cf.SRC
52
+++ b/files/etc/prayer.cf.SRC
5 magnus 53
@@ -20,7 +20,7 @@ var_prefix  = "__VAR_PREFIX__"
3 magnus 54
 # User ID to run as if we start off as root
55
 prayer_user           = "prayer"
56
 # Group ID to run as if we start off as root
57
-prayer_group          = "prayer"
58
+prayer_group          = "nogroup"
59
 
60
 # Run prayer as background process.
61
 #   TRUE => will return as soon as valid configuration is found.
35 magnus 62
@@ -271,11 +271,11 @@ http_icon_embed   = TRUE
3 magnus 63
 
35 magnus 64
 # Locatation of SSL certificate file (only used if SSL ports defined).
65
 # Required if we are going to provide SSL services.
66
-ssl_cert_file       = "$prefix/certs/prayer.pem"
67
+ssl_cert_file       = "/etc/ssl/certs/ssl-cert-snakeoil.pem"
68
 
69
 # Locatation of SSL private key file (only used if SSL ports defined).
70
 # Required if we are going to provide SSL services.
71
-ssl_privatekey_file = "$prefix/certs/prayer.pem"
72
+ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key"
73
 
74
 # Master server will regenerate shared RSA key at this interval:
75
 ssl_rsakey_lifespan = 15m
76
@@ -283,26 +283,14 @@ ssl_rsakey_lifespan = 15m
77
 # RSA key remains fresh in child process for this long after first actual use.
78
 ssl_rsakey_freshen  = 15m
79
 
80
-# SSL session cache timeout.
81
-ssl_session_timeout = 24h
82
+# SSL session cache timeout. Uncomment to enable SSL session caching.
83
+# You should also arrange for prayer-ssl-prune to be run periodically.
84
+#ssl_session_timeout = 24h
85
 
86
 # EGD socket, if system has no /dev/urandom
87
 #egd_socket = "/var/prngd/urandom"
88
 
89
 ######################################################################
90
-
91
-# Direct connection stuff. Experimental! Leave this well alone unless you
92
-# understand what it is for (DESIGN document provides detail for the curious).
93
-direct_enable       = FALSE
94
-
95
-# Following four options just define a set of (non-overlapping) ports for
96
-# SSL and plaintext use if direct connection mode is enabled.
97
-direct_ssl_first    = 5000
98
-direct_ssl_count    = 1000
99
-direct_plain_first  = 4000
100
-direct_plain_count  = 1000
101
-
102
-######################################################################
103
 # Session specific configuration
104
 
105
 # Session switches to idle mode after this much time: connections to IMAP
106
@@ -387,13 +375,13 @@ ispell_path         = /usr/bin/ispell
107
 #  <login_suffix_path>
108
 
109
 # Login page prefix
110
-#login_prefix_path   = "$prefix/etc/login_prefix.html"
111
+#login_prefix_path   = "/etc/login_prefix.html"
112
 
113
 # Message of the day file
114
-#motd_path           = "$prefix/etc/motd.html"
115
+#motd_path           = "/etc/motd.html"
116
 
117
 # Login page suffix
118
-#login_suffix_path   = "$prefix/etc/login_suffix.html"
119
+#login_suffix_path   = "/etc/login_suffix.html"
120
 
121
 # Login security: Prayer's front page defaults to a login form.
122
 # If the user does not connect via SSL then this can be changed
123
@@ -431,10 +419,7 @@ bin_dir             = "__BIN_DIR__"
124
 
3 magnus 125
 # Various directories used by the running system
126
 # Logs stored in $log_dir
127
-log_dir             = "$var_prefix/logs"
128
+log_dir             = "/var/log/prayer"
35 magnus 129
-
130
-# $lock_dir used for interlocking between prayer processes
3 magnus 131
-lock_dir            = "$var_prefix/locks"
132
 
133
 # $socket_dir is location for unix domain sockets which connect frontend
134
 # to backend in proxy mode of operation.
35 magnus 135
@@ -442,7 +427,7 @@ socket_dir          = "$var_prefix/socke
3 magnus 136
 
137
 # Split socket directory into 64 subdirs keyed on first letter of sessionID
138
 # Code provides compatibility in both directions: can switch back and forward
23 magnus 139
-socket_split_dir    = TRUE
140
+socket_split_dir    = FALSE
3 magnus 141
 
23 magnus 142
 # Name of Unix domain socket (in $socket_dir) used for initial handshake
143
 # between prayer and prayer-session processes when a user logs in
35 magnus 144
@@ -453,10 +438,10 @@ ssl_session_dir     = "$var_prefix/ssl_s
3 magnus 145
 
146
 # Location for temporary files e.g; attachments and folders in transist
147
 # during upload and download operation. Core files also end up here
148
-tmp_dir             = "$var_prefix/tmp"
149
+tmp_dir             = "/tmp"
150
 
151
 # Location for PID files for prayer and prayer-session master processes.
152
-pid_dir             = "$var_prefix/pid"
23 magnus 153
+pid_dir             = "$var_prefix"
3 magnus 154
 
155
 # Interface to Hermes finger database
156
 #lookup_rpasswd   = "/data/finger/rpasswd.cdb"
35 magnus 157
@@ -617,14 +602,14 @@ hiersep             = "/"
158
 dualuse             = FALSE
159
 
160
 # Names of postponed_folder and sent_mail_folder, relative to maildir
161
-postponed_folder    = "postponed-msgs"
162
-sent_mail_folder    = "sent-mail"
163
+postponed_folder    = "Drafts"
164
+sent_mail_folder    = "Sent"
165
 
166
 # Default domain for outgoing mail. Defaults to "$hostname".
3 magnus 167
 # default_domain      = "<valid mail domain>"
168
 
169
 # Language for ispell.
170
-ispell_language     = "british"
171
+ispell_language     = "american"
172
 
173
 # Size of small and large compose windows
174
 small_cols          = 80