Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 45 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
45 magnus 1
--- a/lib/mydb_db3.c
2
+++ b/lib/mydb_db3.c
3
@@ -289,9 +289,6 @@ static int myarchive(const char **fnames
4
     const char **fname;
5
     char dstname[1024], *dp;
6
 
7
-    strcpy(dstname, dirname);
8
-    dp = dstname + strlen(dstname);
9
-
10
     /* Get the list of log files to remove. */
11
     r = log_archive(dbenv, &list, DB_ARCH_ABS, NULL);
12
     if (r) {
13
@@ -312,6 +309,11 @@ static int myarchive(const char **fnames
14
        free (begin);
15
     }
16
 
17
+    if (!dirname) return 0;
18
+
19
+    strcpy(dstname, dirname);
20
+    dp = dstname + strlen(dstname);
21
+
22
     /* Get the list of database files to archive. */
23
     /* XXX  Should we do this, or just use the list given to us? */
24
     r = log_archive(dbenv, &list, DB_ARCH_ABS | DB_ARCH_DATA, NULL);
25
--- a/lib/ssl.c
26
+++ b/lib/ssl.c
27
@@ -837,6 +837,7 @@ int ssl_prune_sessions(struct ssl_config
28
     log_debug("tls_prune: purged %d out of %d entries",
29
               prock.deletions, prock.count);
30
 
31
+    DB->archive(NULL, NULL);
32
     DB->done();
33
 
34
     return (0);