Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 46 | Blame | Compare with Previous | Last modification | View Log | RSS feed

--- a/lib/template.c
+++ b/lib/template.c
@@ -199,10 +199,11 @@ template_find(char *set, char *name, str
     unsigned long first, last, middle;
     int rc;
 
-    while (strcmp(tmi->name, set) != 0)
+    while (strcmp(tmi->name, set) != 0) {
         tmi++;
-    if (!tmi->name)
-        return(NIL);
+        if (!tmi->name)
+            return(NIL);
+    }
 
     tm    = tmi->template_map;
     count = *(tmi->count);
--- a/shared/config.c
+++ b/shared/config.c
@@ -168,7 +168,7 @@ struct config *config_create(void)
     config->fatal_dump_core = NIL;
 
     config->template_path = "../templates";
-    config->template_set  = "html4";
+    config->template_set  = "xhtml_strict";
     config->template_use_compiled = T;
 
     config->prayer_user = NIL;