Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 80 | Blame | Compare with Previous | Last modification | View Log | RSS feed

--- a/files/etc/prayer-accountd.cf
+++ b/files/etc/prayer-accountd.cf
@@ -8,6 +8,10 @@
 # Default accountd.cf file suitable for RedHat Linux only.
 # See distribution for some sample files for FreeBSD and Solaris
 
+accountd_port = 145
+
+authtype = pam
+
 msforward_name      = ".MSforward"
 forward_name        = ".forward"
 aliases_name        = "vacation.aliases"
--- a/files/Makefile
+++ b/files/Makefile
@@ -65,21 +65,16 @@ install-aconfig:
 
 install-motd:
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
-       etc/motd.html ${BROOT}${PREFIX}/etc
+       etc/motd.html ${BROOT}/etc/prayer
 
 install:
-       PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \
-       RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \
-       RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \
-       PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \
-       PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \
-       PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \
-       BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
-       ./install.sh
-       if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX}
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer
+
+       tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x
        if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
        if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
-       if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
+       if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi
 
 redhat-install-init.d:
        install -D -o root -g root -m 755 \
--- a/files/etc/prayer.cf.SRC
+++ b/files/etc/prayer.cf.SRC
@@ -20,7 +20,7 @@ var_prefix  = "__VAR_PREFIX__"
 # User ID to run as if we start off as root
 prayer_user           = "prayer"
 # Group ID to run as if we start off as root
-prayer_group          = "prayer"
+prayer_group          = "nogroup"
 
 # Run prayer as background process.
 #   TRUE => will return as soon as valid configuration is found.
@@ -53,7 +53,7 @@ directory_perms       = 0750
 imapd_user_map      = ""
 
 # Default imapd server.
-imapd_server        = localhost
+imapd_server        = localhost/notls
 
 # Name of Prayer user preferences file on IMAP server
 prefs_folder_name   = ".prayer"
@@ -266,11 +266,11 @@ http_icon_embed   = TRUE
 
 # Locatation of SSL certificate file (only used if SSL ports defined).
 # Required if we are going to provide SSL services.
-ssl_cert_file       = "$prefix/certs/prayer.pem"
+ssl_cert_file       = "/etc/ssl/certs/ssl-cert-snakeoil.pem"
 
 # Locatation of SSL private key file (only used if SSL ports defined).
 # Required if we are going to provide SSL services.
-ssl_privatekey_file = "$prefix/certs/prayer.pem"
+ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key"
 
 # Master server will regenerate shared RSA key at this interval:
 ssl_rsakey_lifespan = 15m
@@ -278,26 +278,14 @@ ssl_rsakey_lifespan = 15m
 # RSA key remains fresh in child process for this long after first actual use.
 ssl_rsakey_freshen  = 15m
 
-# SSL session cache timeout.
-ssl_session_timeout = 24h
+# SSL session cache timeout. Uncomment to enable SSL session caching.
+# You should also arrange for prayer-ssl-prune to be run periodically.
+#ssl_session_timeout = 24h
 
 # EGD socket, if system has no /dev/urandom
 #egd_socket = "/var/prngd/urandom"
 
 ######################################################################
-
-# Direct connection stuff. Experimental! Leave this well alone unless you
-# understand what it is for (DESIGN document provides detail for the curious).
-direct_enable       = FALSE
-
-# Following four options just define a set of (non-overlapping) ports for
-# SSL and plaintext use if direct connection mode is enabled.
-direct_ssl_first    = 5000
-direct_ssl_count    = 1000
-direct_plain_first  = 4000
-direct_plain_count  = 1000
-
-######################################################################
 # Session specific configuration
 
 # Session switches to idle mode after this much time: connections to IMAP
@@ -382,13 +370,13 @@ ispell_path         = /usr/bin/ispell
 #  <login_suffix_path>
 
 # Login page prefix
-#login_prefix_path   = "$prefix/etc/login_prefix.html"
+#login_prefix_path   = "/etc/login_prefix.html"
 
 # Message of the day file
-#motd_path           = "$prefix/etc/motd.html"
+#motd_path           = "/etc/prayer/motd.html"
 
 # Login page suffix
-#login_suffix_path   = "$prefix/etc/login_suffix.html"
+#login_suffix_path   = "/etc/login_suffix.html"
 
 # Login security: Prayer's front page defaults to a login form.
 # If the user does not connect via SSL then this can be changed
@@ -409,9 +397,6 @@ ssl_required        = FALSE
 # Session banner (local HTML inserted into each page of login session)
 #session_banner_path = "$prefix/etc/session_banner.html"
 
-# Location of help files
-help_dir            = "$prefix/help"
-
 # Location of icon files
 icon_dir            = "$prefix/icons"
 
@@ -423,10 +408,11 @@ bin_dir             = "__BIN_DIR__"
 
 # Various directories used by the running system
 # Logs stored in $log_dir
-log_dir             = "$var_prefix/logs"
+log_dir             = "/var/log/prayer"
 
 # $lock_dir used for interlocking between prayer processes
-lock_dir            = "$var_prefix/locks"
+# (only on Debian GNU/kFreeBSD)
+lock_dir            = "$var_prefix"
 
 # $socket_dir is location for unix domain sockets which connect frontend
 # to backend in proxy mode of operation.
@@ -434,7 +420,7 @@ socket_dir          = "$var_prefix/socke
 
 # Split socket directory into 64 subdirs keyed on first letter of sessionID
 # Code provides compatibility in both directions: can switch back and forward
-socket_split_dir    = TRUE
+socket_split_dir    = FALSE
 
 # Name of Unix domain socket (in $socket_dir) used for initial handshake
 # between prayer and prayer-session processes when a user logs in
@@ -448,7 +434,7 @@ ssl_session_dir     = "$var_prefix/ssl_s
 tmp_dir             = "$var_prefix/tmp"
 
 # Location for PID files for prayer and prayer-session master processes.
-pid_dir             = "$var_prefix/pid"
+pid_dir             = "$var_prefix"
 
 # Interface to Hermes finger database
 #lookup_rpasswd   = "/data/finger/rpasswd.cdb"
@@ -609,14 +595,14 @@ hiersep             = "/"
 dualuse             = FALSE
 
 # Names of postponed_folder and sent_mail_folder, relative to maildir
-postponed_folder    = "postponed-msgs"
-sent_mail_folder    = "sent-mail"
+postponed_folder    = "Drafts"
+sent_mail_folder    = "Sent"
 
 # Default domain for outgoing mail. Defaults to "$hostname".
 # default_domain      = "<valid mail domain>"
 
 # Language for ispell.
-ispell_language     = "british"
+ispell_language     = "american"
 
 # Size of small and large compose windows
 small_cols          = 80
--- a/shared/config.c
+++ b/shared/config.c
@@ -2139,12 +2139,10 @@ BOOL config_check(struct config * config
     struct config_http_port *chp;
     char hostname[MAX_ADDRESS+1], domainname[MAX_ADDRESS+1];
 
-    TEST_STRING(config->help_dir, "help_dir");
     TEST_STRING(config->icon_dir, "icon_dir");
     TEST_STRING(config->socket_dir, "socket_dir");
     TEST_STRING(config->init_socket_name, "init_socket_name");
     TEST_STRING(config->ssl_session_dir, "ssl_session_dir");
-    TEST_STRING(config->lock_dir, "lock_dir");
     TEST_STRING(config->log_dir, "log_dir");
     TEST_STRING(config->tmp_dir, "tmp_dir");
     TEST_STRING(config->pid_dir, "pid_dir");