Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
174 | magnus | 1 | Description: drop wrong prototype for crypt() |
2 | The code provides its own protoype for crypt, claiming that Linux doesn't |
||
3 | have one in its system headers. Not only is that wrong, but the local |
||
4 | prototype is now incorrect, causing a build failure. |
||
5 | Author: Steve Langasek <steve.langasek@ubuntu.com> |
||
6 | Last-Modified: 2018-11-15 |
||
7 | |||
8 | Index: prayer-1.3.5-dfsg1/accountd/authenticate.c |
||
9 | =================================================================== |
||
10 | --- prayer-1.3.5-dfsg1.orig/accountd/authenticate.c |
||
11 | +++ prayer-1.3.5-dfsg1/accountd/authenticate.c |
||
12 | @@ -94,11 +94,6 @@ |
||
13 | /* Definies a whole series of different authentication methods, including |
||
14 | * PAM if PAM support configured in ../Config */ |
||
15 | |||
16 | -/* No prototype for crypt, at least on Linux */ |
||
17 | -#if HAVE_SHADOW |
||
18 | -extern char *crypt(char *password, char *salt); |
||
19 | -#endif |
||
20 | - |
||
21 | /* ====================================================================== */ |
||
22 | |||
23 | #ifdef ACCOUNTD_PAM_ENABLE |