Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
130 | magnus | 1 | --- a/lib/setproctitle.h |
2 | +++ b/lib/setproctitle.h |
||
3 | @@ -8,7 +8,9 @@ |
||
4 | |||
5 | #include <sys/param.h> |
||
6 | |||
7 | -#ifdef __linux__ |
||
8 | +#if defined(__GNU__) |
||
9 | +# define SPT_TYPE SPT_CHANGEARGV |
||
10 | +#elif defined(__linux__) |
||
11 | # define SPT_TYPE SPT_REUSEARGV |
||
12 | # define SPT_PADCHAR '\0' /* pad process title with nulls */ |
||
13 | #elif (defined(BSD) && BSD >= 199306) |