Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 130 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
130 magnus 1
--- a/lib/setproctitle.h
2
+++ b/lib/setproctitle.h
3
@@ -8,7 +8,9 @@
4
 
5
 #include <sys/param.h>
6
 
7
-#ifdef __linux__
8
+#if defined(__GNU__)
9
+# define SPT_TYPE       SPT_CHANGEARGV
10
+#elif defined(__linux__)
11
 # define SPT_TYPE      SPT_REUSEARGV
12
 # define SPT_PADCHAR   '\0'    /* pad process title with nulls */
13
 #elif (defined(BSD) && BSD >= 199306)
150 magnus 14
--- a/accountd/authenticate.c
15
+++ b/accountd/authenticate.c
16
@@ -8,11 +8,7 @@
17
 
18
 #include "accountd.h"
19
 
20
-#ifdef BSD4_4
21
-#define HAVE_SHADOW 0
22
-#else
23
 #define HAVE_SHADOW 1
24
-#endif
25
 
26
 #include <pwd.h>
27
 #if HAVE_SHADOW