Rev 50 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
50 | magnus | 1 | --- a/lib/os.c |
2 | +++ b/lib/os.c |
||
3 | @@ -26,7 +26,7 @@ |
||
4 | #include "os_linux.c" |
||
5 | #elif (defined(SOLARIS)) |
||
6 | #include "os_solaris.c" |
||
7 | -#elif (defined(BSD) && BSD >= 199306) |
||
8 | +#elif defined(__FreeBSD_kernel__) || (defined(BSD) && BSD >= 199306) |
||
9 | #include "os_bsd.c" |
||
10 | #else |
||
11 | #error "No support for this operating system yet. Sorry!" |
||
12 | --- a/lib/os_bsd.c |
||
13 | +++ b/lib/os_bsd.c |
||
79 | magnus | 14 | @@ -16,8 +16,13 @@ |
50 | magnus | 15 | #include <arpa/inet.h> |
16 | #include <signal.h> |
||
17 | #include <netdb.h> |
||
79 | magnus | 18 | - |
50 | magnus | 19 | +#ifdef __GLIBC__ |
20 | +#include <sys/file.h> |
||
21 | +#include <pty.h> |
||
22 | +#endif |
||
79 | magnus | 23 | +#else |
50 | magnus | 24 | #include <libutil.h> |
79 | magnus | 25 | +#endif |
50 | magnus | 26 | |
79 | magnus | 27 | /* ====================================================================== */ |
28 | |||
29 | --- a/lib/mymutex.c |
||
30 | +++ b/lib/mymutex.c |
||
31 | @@ -9,7 +9,7 @@ |
||
32 | |||
33 | #include "lib.h" |
||
34 | |||
35 | -#ifdef MUTEX_SEMAPHORE |
||
36 | +#if defined(MUTEX_SEMAPHORE) && !defined(__stub_semtimedop) |
||
37 | # include "mymutex_sem.c" |
||
38 | #else |
||
39 | # include "mymutex_file.c" |