Rev 113 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
12 | magnus | 1 | --- a/files/etc/prayer-accountd.cf |
2 | +++ b/files/etc/prayer-accountd.cf |
||
15 | magnus | 3 | @@ -8,6 +8,10 @@ |
3 | magnus | 4 | # Default accountd.cf file suitable for RedHat Linux only. |
5 | # See distribution for some sample files for FreeBSD and Solaris |
||
6 | |||
7 | +accountd_port = 145 |
||
8 | + |
||
15 | magnus | 9 | +authtype = pam |
10 | + |
||
3 | magnus | 11 | msforward_name = ".MSforward" |
12 | forward_name = ".forward" |
||
13 | aliases_name = "vacation.aliases" |
||
12 | magnus | 14 | --- a/files/Makefile |
15 | +++ b/files/Makefile |
||
86 | magnus | 16 | @@ -66,21 +66,16 @@ install-aconfig: |
3 | magnus | 17 | |
18 | install-motd: |
||
19 | $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \ |
||
20 | - etc/motd.html ${BROOT}${PREFIX}/etc |
||
23 | magnus | 21 | + etc/motd.html ${BROOT}/etc/prayer |
3 | magnus | 22 | |
23 | install: |
||
44 | magnus | 24 | - PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \ |
25 | - RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \ |
||
26 | - RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \ |
||
27 | - PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \ |
||
28 | - PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \ |
||
29 | - PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \ |
||
30 | - BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \ |
||
31 | - ./install.sh |
||
32 | - if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi |
||
23 | magnus | 33 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX} |
34 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer |
||
3 | magnus | 35 | + |
96 | magnus | 36 | + tar -c --owner ${RO_USER} --group ${RO_GROUP} --mode "a-x+X" icons static | tar -C ${BROOT}${PREFIX} -x |
23 | magnus | 37 | if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi |
38 | if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi |
||
3 | magnus | 39 | - if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi |
23 | magnus | 40 | + if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi |
3 | magnus | 41 | |
42 | redhat-install-init.d: |
||
43 | install -D -o root -g root -m 755 \ |
||
12 | magnus | 44 | --- a/files/etc/prayer.cf.SRC |
45 | +++ b/files/etc/prayer.cf.SRC |
||
5 | magnus | 46 | @@ -20,7 +20,7 @@ var_prefix = "__VAR_PREFIX__" |
3 | magnus | 47 | # User ID to run as if we start off as root |
48 | prayer_user = "prayer" |
||
49 | # Group ID to run as if we start off as root |
||
50 | -prayer_group = "prayer" |
||
51 | +prayer_group = "nogroup" |
||
52 | |||
53 | # Run prayer as background process. |
||
54 | # TRUE => will return as soon as valid configuration is found. |
||
80 | magnus | 55 | @@ -53,7 +53,7 @@ directory_perms = 0750 |
56 | imapd_user_map = "" |
||
57 | |||
58 | # Default imapd server. |
||
59 | -imapd_server = localhost |
||
60 | +imapd_server = localhost/notls |
||
61 | |||
62 | # Name of Prayer user preferences file on IMAP server |
||
63 | prefs_folder_name = ".prayer" |
||
86 | magnus | 64 | @@ -270,11 +270,11 @@ icon_expire_timeout = 7d |
3 | magnus | 65 | |
35 | magnus | 66 | # Locatation of SSL certificate file (only used if SSL ports defined). |
67 | # Required if we are going to provide SSL services. |
||
68 | -ssl_cert_file = "$prefix/certs/prayer.pem" |
||
69 | +ssl_cert_file = "/etc/ssl/certs/ssl-cert-snakeoil.pem" |
||
70 | |||
71 | # Locatation of SSL private key file (only used if SSL ports defined). |
||
72 | # Required if we are going to provide SSL services. |
||
73 | -ssl_privatekey_file = "$prefix/certs/prayer.pem" |
||
74 | +ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key" |
||
75 | |||
76 | # Master server will regenerate shared RSA key at this interval: |
||
77 | ssl_rsakey_lifespan = 15m |
||
113 | magnus | 78 | @@ -282,8 +282,9 @@ ssl_rsakey_lifespan = 15m |
35 | magnus | 79 | # RSA key remains fresh in child process for this long after first actual use. |
80 | ssl_rsakey_freshen = 15m |
||
81 | |||
82 | -# SSL session cache timeout. |
||
83 | -ssl_session_timeout = 24h |
||
84 | +# SSL session cache timeout. Uncomment to enable SSL session caching. |
||
85 | +# You should also arrange for prayer-ssl-prune to be run periodically. |
||
86 | +#ssl_session_timeout = 24h |
||
87 | |||
88 | # EGD socket, if system has no /dev/urandom |
||
89 | #egd_socket = "/var/prngd/urandom" |
||
145 | magnus | 90 | @@ -374,13 +375,15 @@ sendmail_path = /usr/lib/sendmail |
86 | magnus | 91 | ispell_path = /usr/bin/ispell |
35 | magnus | 92 | |
93 | # Message of the day file |
||
86 | magnus | 94 | -motd_path = "$prefix/etc/motd.html" |
79 | magnus | 95 | +#motd_path = "/etc/prayer/motd.html" |
35 | magnus | 96 | |
86 | magnus | 97 | -# HTML to insert into login page |
145 | magnus | 98 | -#login_insert1_path = "$prefix/etc/ucsnews.html" |
99 | - |
||
100 | -# HTML to insert into login page |
||
86 | magnus | 101 | -#login_insert2_path = "$prefix/etc/ucsnews.html" |
102 | +# HTML to make available to login template as $login_insert1 |
||
103 | +# (only used in "cam" template set). |
||
104 | +#login_insert1_path = "/etc/prayer/login1.html" |
||
105 | + |
||
106 | +# HTML to make available to login template as $login_insert2 |
||
107 | +# (currently not used in any template set). |
||
108 | +#login_insert2_path = "/etc/prayer/login2.html" |
||
35 | magnus | 109 | |
110 | # Login security: Prayer's front page defaults to a login form. |
||
111 | # If the user does not connect via SSL then this can be changed |
||
145 | magnus | 112 | @@ -409,10 +412,11 @@ bin_dir = "__BIN_DIR__" |
35 | magnus | 113 | |
3 | magnus | 114 | # Various directories used by the running system |
115 | # Logs stored in $log_dir |
||
116 | -log_dir = "$var_prefix/logs" |
||
48 | magnus | 117 | +log_dir = "/var/log/prayer" |
3 | magnus | 118 | |
79 | magnus | 119 | # $lock_dir used for interlocking between prayer processes |
120 | -lock_dir = "$var_prefix/locks" |
||
121 | +# (only on Debian GNU/kFreeBSD) |
||
122 | +lock_dir = "$var_prefix" |
||
123 | |||
3 | magnus | 124 | # $socket_dir is location for unix domain sockets which connect frontend |
125 | # to backend in proxy mode of operation. |
||
145 | magnus | 126 | @@ -420,7 +424,7 @@ socket_dir = "$var_prefix/socke |
3 | magnus | 127 | |
128 | # Split socket directory into 64 subdirs keyed on first letter of sessionID |
||
129 | # Code provides compatibility in both directions: can switch back and forward |
||
23 | magnus | 130 | -socket_split_dir = TRUE |
131 | +socket_split_dir = FALSE |
||
3 | magnus | 132 | |
23 | magnus | 133 | # Name of Unix domain socket (in $socket_dir) used for initial handshake |
134 | # between prayer and prayer-session processes when a user logs in |
||
145 | magnus | 135 | @@ -434,7 +438,7 @@ ssl_session_dir = "$var_prefix/ssl_s |
71 | magnus | 136 | tmp_dir = "$var_prefix/tmp" |
3 | magnus | 137 | |
138 | # Location for PID files for prayer and prayer-session master processes. |
||
139 | -pid_dir = "$var_prefix/pid" |
||
23 | magnus | 140 | +pid_dir = "$var_prefix" |
3 | magnus | 141 | |
142 | # Interface to Hermes finger database |
||
143 | #lookup_rpasswd = "/data/finger/rpasswd.cdb" |
||
145 | magnus | 144 | @@ -452,7 +456,7 @@ pid_dir = "$var_prefix/pid" |
86 | magnus | 145 | # Template stuff |
146 | |||
147 | template_path = "__PREFIX__/templates" |
||
148 | -template_set = "cam" |
||
149 | +template_set = "old" |
||
150 | template_use_compiled = TRUE |
||
151 | |||
152 | template old "Traditional" |
||
145 | magnus | 153 | @@ -601,14 +605,14 @@ hiersep = "/" |
35 | magnus | 154 | dualuse = FALSE |
155 | |||
156 | # Names of postponed_folder and sent_mail_folder, relative to maildir |
||
157 | -postponed_folder = "postponed-msgs" |
||
158 | -sent_mail_folder = "sent-mail" |
||
159 | +postponed_folder = "Drafts" |
||
160 | +sent_mail_folder = "Sent" |
||
161 | |||
162 | # Default domain for outgoing mail. Defaults to "$hostname". |
||
3 | magnus | 163 | # default_domain = "<valid mail domain>" |
164 | |||
165 | # Language for ispell. |
||
166 | -ispell_language = "british" |
||
167 | +ispell_language = "american" |
||
168 | |||
169 | # Size of small and large compose windows |
||
170 | small_cols = 80 |