Rev 48 | Rev 71 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
12 | magnus | 1 | --- a/files/etc/prayer-accountd.cf |
2 | +++ b/files/etc/prayer-accountd.cf |
||
15 | magnus | 3 | @@ -8,6 +8,10 @@ |
3 | magnus | 4 | # Default accountd.cf file suitable for RedHat Linux only. |
5 | # See distribution for some sample files for FreeBSD and Solaris |
||
6 | |||
7 | +accountd_port = 145 |
||
8 | + |
||
15 | magnus | 9 | +authtype = pam |
10 | + |
||
3 | magnus | 11 | msforward_name = ".MSforward" |
12 | forward_name = ".forward" |
||
13 | aliases_name = "vacation.aliases" |
||
12 | magnus | 14 | --- a/files/Makefile |
15 | +++ b/files/Makefile |
||
49 | magnus | 16 | @@ -65,21 +65,16 @@ install-aconfig: |
3 | magnus | 17 | |
18 | install-motd: |
||
19 | $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \ |
||
20 | - etc/motd.html ${BROOT}${PREFIX}/etc |
||
23 | magnus | 21 | + etc/motd.html ${BROOT}/etc/prayer |
3 | magnus | 22 | |
23 | install: |
||
44 | magnus | 24 | - PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \ |
25 | - RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \ |
||
26 | - RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \ |
||
27 | - PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \ |
||
28 | - PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \ |
||
29 | - PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \ |
||
30 | - BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \ |
||
31 | - ./install.sh |
||
32 | - if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi |
||
23 | magnus | 33 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX} |
34 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer |
||
3 | magnus | 35 | + |
44 | magnus | 36 | + tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x |
23 | magnus | 37 | if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi |
38 | if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi |
||
3 | magnus | 39 | - if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi |
23 | magnus | 40 | + if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi |
3 | magnus | 41 | |
42 | redhat-install-init.d: |
||
43 | install -D -o root -g root -m 755 \ |
||
12 | magnus | 44 | --- a/files/etc/prayer.cf.SRC |
45 | +++ b/files/etc/prayer.cf.SRC |
||
5 | magnus | 46 | @@ -20,7 +20,7 @@ var_prefix = "__VAR_PREFIX__" |
3 | magnus | 47 | # User ID to run as if we start off as root |
48 | prayer_user = "prayer" |
||
49 | # Group ID to run as if we start off as root |
||
50 | -prayer_group = "prayer" |
||
51 | +prayer_group = "nogroup" |
||
52 | |||
53 | # Run prayer as background process. |
||
54 | # TRUE => will return as soon as valid configuration is found. |
||
48 | magnus | 55 | @@ -266,11 +266,11 @@ http_icon_embed = TRUE |
3 | magnus | 56 | |
35 | magnus | 57 | # Locatation of SSL certificate file (only used if SSL ports defined). |
58 | # Required if we are going to provide SSL services. |
||
59 | -ssl_cert_file = "$prefix/certs/prayer.pem" |
||
60 | +ssl_cert_file = "/etc/ssl/certs/ssl-cert-snakeoil.pem" |
||
61 | |||
62 | # Locatation of SSL private key file (only used if SSL ports defined). |
||
63 | # Required if we are going to provide SSL services. |
||
64 | -ssl_privatekey_file = "$prefix/certs/prayer.pem" |
||
65 | +ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key" |
||
66 | |||
67 | # Master server will regenerate shared RSA key at this interval: |
||
68 | ssl_rsakey_lifespan = 15m |
||
48 | magnus | 69 | @@ -278,26 +278,14 @@ ssl_rsakey_lifespan = 15m |
35 | magnus | 70 | # RSA key remains fresh in child process for this long after first actual use. |
71 | ssl_rsakey_freshen = 15m |
||
72 | |||
73 | -# SSL session cache timeout. |
||
74 | -ssl_session_timeout = 24h |
||
75 | +# SSL session cache timeout. Uncomment to enable SSL session caching. |
||
76 | +# You should also arrange for prayer-ssl-prune to be run periodically. |
||
77 | +#ssl_session_timeout = 24h |
||
78 | |||
79 | # EGD socket, if system has no /dev/urandom |
||
80 | #egd_socket = "/var/prngd/urandom" |
||
81 | |||
82 | ###################################################################### |
||
83 | - |
||
84 | -# Direct connection stuff. Experimental! Leave this well alone unless you |
||
85 | -# understand what it is for (DESIGN document provides detail for the curious). |
||
86 | -direct_enable = FALSE |
||
87 | - |
||
88 | -# Following four options just define a set of (non-overlapping) ports for |
||
89 | -# SSL and plaintext use if direct connection mode is enabled. |
||
90 | -direct_ssl_first = 5000 |
||
91 | -direct_ssl_count = 1000 |
||
92 | -direct_plain_first = 4000 |
||
93 | -direct_plain_count = 1000 |
||
94 | - |
||
95 | -###################################################################### |
||
96 | # Session specific configuration |
||
97 | |||
98 | # Session switches to idle mode after this much time: connections to IMAP |
||
48 | magnus | 99 | @@ -382,13 +370,13 @@ ispell_path = /usr/bin/ispell |
35 | magnus | 100 | # <login_suffix_path> |
101 | |||
102 | # Login page prefix |
||
103 | -#login_prefix_path = "$prefix/etc/login_prefix.html" |
||
104 | +#login_prefix_path = "/etc/login_prefix.html" |
||
105 | |||
106 | # Message of the day file |
||
107 | -#motd_path = "$prefix/etc/motd.html" |
||
108 | +#motd_path = "/etc/motd.html" |
||
109 | |||
110 | # Login page suffix |
||
111 | -#login_suffix_path = "$prefix/etc/login_suffix.html" |
||
112 | +#login_suffix_path = "/etc/login_suffix.html" |
||
113 | |||
114 | # Login security: Prayer's front page defaults to a login form. |
||
115 | # If the user does not connect via SSL then this can be changed |
||
48 | magnus | 116 | @@ -423,10 +411,7 @@ bin_dir = "__BIN_DIR__" |
35 | magnus | 117 | |
3 | magnus | 118 | # Various directories used by the running system |
119 | # Logs stored in $log_dir |
||
120 | -log_dir = "$var_prefix/logs" |
||
35 | magnus | 121 | - |
122 | -# $lock_dir used for interlocking between prayer processes |
||
3 | magnus | 123 | -lock_dir = "$var_prefix/locks" |
48 | magnus | 124 | +log_dir = "/var/log/prayer" |
3 | magnus | 125 | |
126 | # $socket_dir is location for unix domain sockets which connect frontend |
||
127 | # to backend in proxy mode of operation. |
||
48 | magnus | 128 | @@ -434,7 +419,7 @@ socket_dir = "$var_prefix/socke |
3 | magnus | 129 | |
130 | # Split socket directory into 64 subdirs keyed on first letter of sessionID |
||
131 | # Code provides compatibility in both directions: can switch back and forward |
||
23 | magnus | 132 | -socket_split_dir = TRUE |
133 | +socket_split_dir = FALSE |
||
3 | magnus | 134 | |
23 | magnus | 135 | # Name of Unix domain socket (in $socket_dir) used for initial handshake |
136 | # between prayer and prayer-session processes when a user logs in |
||
48 | magnus | 137 | @@ -445,10 +430,10 @@ ssl_session_dir = "$var_prefix/ssl_s |
3 | magnus | 138 | |
139 | # Location for temporary files e.g; attachments and folders in transist |
||
140 | # during upload and download operation. Core files also end up here |
||
141 | -tmp_dir = "$var_prefix/tmp" |
||
142 | +tmp_dir = "/tmp" |
||
143 | |||
144 | # Location for PID files for prayer and prayer-session master processes. |
||
145 | -pid_dir = "$var_prefix/pid" |
||
23 | magnus | 146 | +pid_dir = "$var_prefix" |
3 | magnus | 147 | |
148 | # Interface to Hermes finger database |
||
149 | #lookup_rpasswd = "/data/finger/rpasswd.cdb" |
||
48 | magnus | 150 | @@ -609,14 +594,14 @@ hiersep = "/" |
35 | magnus | 151 | dualuse = FALSE |
152 | |||
153 | # Names of postponed_folder and sent_mail_folder, relative to maildir |
||
154 | -postponed_folder = "postponed-msgs" |
||
155 | -sent_mail_folder = "sent-mail" |
||
156 | +postponed_folder = "Drafts" |
||
157 | +sent_mail_folder = "Sent" |
||
158 | |||
159 | # Default domain for outgoing mail. Defaults to "$hostname". |
||
3 | magnus | 160 | # default_domain = "<valid mail domain>" |
161 | |||
162 | # Language for ispell. |
||
163 | -ispell_language = "british" |
||
164 | +ispell_language = "american" |
||
165 | |||
166 | # Size of small and large compose windows |
||
167 | small_cols = 80 |