Rev 15 | Rev 35 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
12 | magnus | 1 | --- a/files/etc/prayer-accountd.cf |
2 | +++ b/files/etc/prayer-accountd.cf |
||
15 | magnus | 3 | @@ -8,6 +8,10 @@ |
3 | magnus | 4 | # Default accountd.cf file suitable for RedHat Linux only. |
5 | # See distribution for some sample files for FreeBSD and Solaris |
||
6 | |||
7 | +accountd_port = 145 |
||
8 | + |
||
15 | magnus | 9 | +authtype = pam |
10 | + |
||
3 | magnus | 11 | msforward_name = ".MSforward" |
12 | forward_name = ".forward" |
||
13 | aliases_name = "vacation.aliases" |
||
12 | magnus | 14 | --- a/files/Makefile |
15 | +++ b/files/Makefile |
||
23 | magnus | 16 | @@ -65,26 +65,29 @@ install-aconfig: |
3 | magnus | 17 | |
18 | install-motd: |
||
19 | $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \ |
||
20 | - etc/motd.html ${BROOT}${PREFIX}/etc |
||
23 | magnus | 21 | + etc/motd.html ${BROOT}/etc/prayer |
3 | magnus | 22 | |
23 | install-welcome: |
||
24 | $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \ |
||
25 | - etc/welcome.html ${BROOT}${PREFIX}/etc |
||
23 | magnus | 26 | + etc/welcome.html ${BROOT}/etc/prayer |
3 | magnus | 27 | |
28 | install: |
||
23 | magnus | 29 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX} |
30 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer |
||
3 | magnus | 31 | + |
23 | magnus | 32 | PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \ |
3 | magnus | 33 | RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \ |
34 | RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \ |
||
35 | PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \ |
||
36 | PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \ |
||
37 | PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \ |
||
38 | - BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \ |
||
23 | magnus | 39 | + BIN_DIR=$(BROOT)$(BIN_DIR) INSTALL=$(INSTALL) \ |
3 | magnus | 40 | ./install.sh |
41 | - if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi |
||
23 | magnus | 42 | +# if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi |
43 | if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi |
||
44 | if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi |
||
3 | magnus | 45 | - if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi |
46 | - if [ ! -f $(BROOT)$(PREFIX)/etc/welcome.html ]; then $(MAKE) install-welcome; fi |
||
23 | magnus | 47 | + if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi |
48 | + if [ ! -f $(BROOT)/etc/prayer/welcome.html ]; then $(MAKE) install-welcome; fi |
||
3 | magnus | 49 | |
50 | redhat-install-init.d: |
||
51 | install -D -o root -g root -m 755 \ |
||
12 | magnus | 52 | --- a/files/install.sh |
53 | +++ b/files/install.sh |
||
3 | magnus | 54 | @@ -4,77 +4,6 @@ |
55 | |||
56 | PATH=/bin:/sbin/:/usr/bin:/usr/sbin |
||
57 | |||
58 | -error=0 |
||
59 | - |
||
60 | -if [ "x$PREFIX" = "x" ]; then |
||
61 | - echo 'PREFIX not defined' |
||
62 | - error=1 |
||
63 | -fi |
||
64 | - |
||
65 | -if [ "x$VAR_PREFIX" = "x" ]; then |
||
66 | - echo 'VAR_PREFIX not defined' |
||
67 | - error=1 |
||
68 | -fi |
||
69 | - |
||
70 | -if [ "x$RO_USER" = "x" ]; then |
||
71 | - echo 'RO_USER not defined' |
||
72 | - error=1 |
||
73 | -fi |
||
74 | - |
||
75 | -if [ "x$RO_GROUP" = "x" ]; then |
||
76 | - echo 'RO_GROUP not defined' |
||
77 | - error=1 |
||
78 | -fi |
||
79 | - |
||
80 | -if [ "x$RW_USER" = "x" ]; then |
||
81 | - echo 'RW_USER not defined' |
||
82 | - error=1 |
||
83 | -fi |
||
84 | - |
||
85 | -if [ "x$RW_GROUP" = "x" ]; then |
||
86 | - echo 'RW_GROUP not defined' |
||
87 | - error=1 |
||
88 | -fi |
||
89 | - |
||
90 | -if [ "x$PUBLIC_DIR" = "x" ]; then |
||
91 | - echo 'PUBLIC_DIR not defined' |
||
92 | - error=1 |
||
93 | -fi |
||
94 | - |
||
95 | -if [ "x$PRIVATE_DIR" = "x" ]; then |
||
96 | - echo 'PRIVATE_DIR not defined' |
||
97 | - error=1 |
||
98 | -fi |
||
99 | - |
||
100 | -if [ "x$BIN_DIR" = "x" ]; then |
||
101 | - echo 'BIN_DIR not defined' |
||
102 | - error=1 |
||
103 | -fi |
||
104 | - |
||
105 | -if [ $error != 0 ]; then |
||
106 | - exit 1 |
||
107 | -fi |
||
108 | - |
||
109 | -if [ ! -d ${VAR_PREFIX} -a `whoami` = "root" ]; then |
||
110 | - ${INSTALL} -d -o ${RW_USER} -g ${RW_GROUP} -m ${PRIVATE_DIR} ${VAR_PREFIX} |
||
111 | -fi |
||
112 | - |
||
113 | -if [ ! -d ${PREFIX} ]; then |
||
114 | - ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${PREFIX} |
||
115 | -fi |
||
116 | - |
||
117 | -if [ ! -d ${PREFIX}/etc ]; then |
||
118 | - ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${PREFIX}/etc |
||
119 | -fi |
||
120 | - |
||
121 | -if [ ! -d ${PREFIX}/certs ]; then |
||
122 | - ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PRIVATE_DIR} ${PREFIX}/certs |
||
123 | -fi |
||
124 | - |
||
125 | -if [ ! -d ${BIN_DIR} ]; then |
||
5 | magnus | 126 | - ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BIN_DIR} |
3 | magnus | 127 | -fi |
128 | - |
||
23 | magnus | 129 | for i in icons |
3 | magnus | 130 | do |
131 | if [ -d "${PREFIX}/${i}" ]; then |
||
12 | magnus | 132 | --- a/files/etc/prayer.cf.SRC |
133 | +++ b/files/etc/prayer.cf.SRC |
||
5 | magnus | 134 | @@ -20,7 +20,7 @@ var_prefix = "__VAR_PREFIX__" |
3 | magnus | 135 | # User ID to run as if we start off as root |
136 | prayer_user = "prayer" |
||
137 | # Group ID to run as if we start off as root |
||
138 | -prayer_group = "prayer" |
||
139 | +prayer_group = "nogroup" |
||
140 | |||
141 | # Run prayer as background process. |
||
142 | # TRUE => will return as soon as valid configuration is found. |
||
23 | magnus | 143 | @@ -428,10 +428,10 @@ bin_dir = "__BIN_DIR__" |
3 | magnus | 144 | |
145 | # Various directories used by the running system |
||
146 | # Logs stored in $log_dir |
||
147 | -log_dir = "$var_prefix/logs" |
||
148 | +log_dir = "/var/log/prayer" |
||
149 | |||
150 | # $lock_dir used for interlocking between prayer processes |
||
151 | -lock_dir = "$var_prefix/locks" |
||
152 | +lock_dir = "/var/lock" |
||
153 | |||
154 | # $socket_dir is location for unix domain sockets which connect frontend |
||
155 | # to backend in proxy mode of operation. |
||
23 | magnus | 156 | @@ -439,7 +439,7 @@ socket_dir = "$var_prefix/socke |
3 | magnus | 157 | |
158 | # Split socket directory into 64 subdirs keyed on first letter of sessionID |
||
159 | # Code provides compatibility in both directions: can switch back and forward |
||
23 | magnus | 160 | -socket_split_dir = TRUE |
161 | +socket_split_dir = FALSE |
||
3 | magnus | 162 | |
23 | magnus | 163 | # Name of Unix domain socket (in $socket_dir) used for initial handshake |
164 | # between prayer and prayer-session processes when a user logs in |
||
165 | @@ -450,10 +450,10 @@ ssl_session_dir = "$var_prefix/ssl_s |
||
3 | magnus | 166 | |
167 | # Location for temporary files e.g; attachments and folders in transist |
||
168 | # during upload and download operation. Core files also end up here |
||
169 | -tmp_dir = "$var_prefix/tmp" |
||
170 | +tmp_dir = "/tmp" |
||
171 | |||
172 | # Location for PID files for prayer and prayer-session master processes. |
||
173 | -pid_dir = "$var_prefix/pid" |
||
23 | magnus | 174 | +pid_dir = "$var_prefix" |
3 | magnus | 175 | |
176 | # Interface to Hermes finger database |
||
177 | #lookup_rpasswd = "/data/finger/rpasswd.cdb" |
||
23 | magnus | 178 | @@ -621,7 +621,7 @@ sent_mail_folder = "sent-mail" |
3 | magnus | 179 | # default_domain = "<valid mail domain>" |
180 | |||
181 | # Language for ispell. |
||
182 | -ispell_language = "british" |
||
183 | +ispell_language = "american" |
||
184 | |||
185 | # Size of small and large compose windows |
||
186 | small_cols = 80 |