Rev 86 | Rev 96 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
12 | magnus | 1 | --- a/files/etc/prayer-accountd.cf |
2 | +++ b/files/etc/prayer-accountd.cf |
||
15 | magnus | 3 | @@ -8,6 +8,10 @@ |
3 | magnus | 4 | # Default accountd.cf file suitable for RedHat Linux only. |
5 | # See distribution for some sample files for FreeBSD and Solaris |
||
6 | |||
7 | +accountd_port = 145 |
||
8 | + |
||
15 | magnus | 9 | +authtype = pam |
10 | + |
||
3 | magnus | 11 | msforward_name = ".MSforward" |
12 | forward_name = ".forward" |
||
13 | aliases_name = "vacation.aliases" |
||
12 | magnus | 14 | --- a/files/Makefile |
15 | +++ b/files/Makefile |
||
86 | magnus | 16 | @@ -66,21 +66,16 @@ install-aconfig: |
3 | magnus | 17 | |
18 | install-motd: |
||
19 | $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \ |
||
20 | - etc/motd.html ${BROOT}${PREFIX}/etc |
||
23 | magnus | 21 | + etc/motd.html ${BROOT}/etc/prayer |
3 | magnus | 22 | |
23 | install: |
||
44 | magnus | 24 | - PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \ |
25 | - RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \ |
||
26 | - RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \ |
||
27 | - PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \ |
||
28 | - PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \ |
||
29 | - PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \ |
||
30 | - BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \ |
||
31 | - ./install.sh |
||
32 | - if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi |
||
23 | magnus | 33 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX} |
34 | + ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer |
||
3 | magnus | 35 | + |
44 | magnus | 36 | + tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x |
23 | magnus | 37 | if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi |
38 | if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi |
||
3 | magnus | 39 | - if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi |
23 | magnus | 40 | + if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi |
3 | magnus | 41 | |
42 | redhat-install-init.d: |
||
43 | install -D -o root -g root -m 755 \ |
||
12 | magnus | 44 | --- a/files/etc/prayer.cf.SRC |
45 | +++ b/files/etc/prayer.cf.SRC |
||
5 | magnus | 46 | @@ -20,7 +20,7 @@ var_prefix = "__VAR_PREFIX__" |
3 | magnus | 47 | # User ID to run as if we start off as root |
48 | prayer_user = "prayer" |
||
49 | # Group ID to run as if we start off as root |
||
50 | -prayer_group = "prayer" |
||
51 | +prayer_group = "nogroup" |
||
52 | |||
53 | # Run prayer as background process. |
||
54 | # TRUE => will return as soon as valid configuration is found. |
||
80 | magnus | 55 | @@ -53,7 +53,7 @@ directory_perms = 0750 |
56 | imapd_user_map = "" |
||
57 | |||
58 | # Default imapd server. |
||
59 | -imapd_server = localhost |
||
60 | +imapd_server = localhost/notls |
||
61 | |||
62 | # Name of Prayer user preferences file on IMAP server |
||
63 | prefs_folder_name = ".prayer" |
||
86 | magnus | 64 | @@ -270,11 +270,11 @@ icon_expire_timeout = 7d |
3 | magnus | 65 | |
35 | magnus | 66 | # Locatation of SSL certificate file (only used if SSL ports defined). |
67 | # Required if we are going to provide SSL services. |
||
68 | -ssl_cert_file = "$prefix/certs/prayer.pem" |
||
69 | +ssl_cert_file = "/etc/ssl/certs/ssl-cert-snakeoil.pem" |
||
70 | |||
71 | # Locatation of SSL private key file (only used if SSL ports defined). |
||
72 | # Required if we are going to provide SSL services. |
||
73 | -ssl_privatekey_file = "$prefix/certs/prayer.pem" |
||
74 | +ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key" |
||
75 | |||
76 | # Master server will regenerate shared RSA key at this interval: |
||
77 | ssl_rsakey_lifespan = 15m |
||
86 | magnus | 78 | @@ -282,26 +282,14 @@ ssl_rsakey_lifespan = 15m |
35 | magnus | 79 | # RSA key remains fresh in child process for this long after first actual use. |
80 | ssl_rsakey_freshen = 15m |
||
81 | |||
82 | -# SSL session cache timeout. |
||
83 | -ssl_session_timeout = 24h |
||
84 | +# SSL session cache timeout. Uncomment to enable SSL session caching. |
||
85 | +# You should also arrange for prayer-ssl-prune to be run periodically. |
||
86 | +#ssl_session_timeout = 24h |
||
87 | |||
88 | # EGD socket, if system has no /dev/urandom |
||
89 | #egd_socket = "/var/prngd/urandom" |
||
90 | |||
91 | ###################################################################### |
||
92 | - |
||
93 | -# Direct connection stuff. Experimental! Leave this well alone unless you |
||
94 | -# understand what it is for (DESIGN document provides detail for the curious). |
||
95 | -direct_enable = FALSE |
||
96 | - |
||
97 | -# Following four options just define a set of (non-overlapping) ports for |
||
98 | -# SSL and plaintext use if direct connection mode is enabled. |
||
99 | -direct_ssl_first = 5000 |
||
100 | -direct_ssl_count = 1000 |
||
101 | -direct_plain_first = 4000 |
||
102 | -direct_plain_count = 1000 |
||
103 | - |
||
104 | -###################################################################### |
||
105 | # Session specific configuration |
||
106 | |||
107 | # Session switches to idle mode after this much time: connections to IMAP |
||
86 | magnus | 108 | @@ -376,13 +364,15 @@ sendmail_path = /usr/lib/sendmail |
109 | ispell_path = /usr/bin/ispell |
||
35 | magnus | 110 | |
111 | # Message of the day file |
||
86 | magnus | 112 | -motd_path = "$prefix/etc/motd.html" |
113 | - |
||
114 | -# HTML to insert into login page |
||
115 | -#login_insert1_path = "$prefix/etc/ucsnews.html" |
||
79 | magnus | 116 | +#motd_path = "/etc/prayer/motd.html" |
35 | magnus | 117 | |
86 | magnus | 118 | -# HTML to insert into login page |
119 | -#login_insert2_path = "$prefix/etc/ucsnews.html" |
||
120 | +# HTML to make available to login template as $login_insert1 |
||
121 | +# (only used in "cam" template set). |
||
122 | +#login_insert1_path = "/etc/prayer/login1.html" |
||
123 | + |
||
124 | +# HTML to make available to login template as $login_insert2 |
||
125 | +# (currently not used in any template set). |
||
126 | +#login_insert2_path = "/etc/prayer/login2.html" |
||
35 | magnus | 127 | |
128 | # Login security: Prayer's front page defaults to a login form. |
||
129 | # If the user does not connect via SSL then this can be changed |
||
86 | magnus | 130 | @@ -411,10 +401,11 @@ bin_dir = "__BIN_DIR__" |
35 | magnus | 131 | |
3 | magnus | 132 | # Various directories used by the running system |
133 | # Logs stored in $log_dir |
||
134 | -log_dir = "$var_prefix/logs" |
||
48 | magnus | 135 | +log_dir = "/var/log/prayer" |
3 | magnus | 136 | |
79 | magnus | 137 | # $lock_dir used for interlocking between prayer processes |
138 | -lock_dir = "$var_prefix/locks" |
||
139 | +# (only on Debian GNU/kFreeBSD) |
||
140 | +lock_dir = "$var_prefix" |
||
141 | |||
3 | magnus | 142 | # $socket_dir is location for unix domain sockets which connect frontend |
143 | # to backend in proxy mode of operation. |
||
86 | magnus | 144 | @@ -422,7 +413,7 @@ socket_dir = "$var_prefix/socke |
3 | magnus | 145 | |
146 | # Split socket directory into 64 subdirs keyed on first letter of sessionID |
||
147 | # Code provides compatibility in both directions: can switch back and forward |
||
23 | magnus | 148 | -socket_split_dir = TRUE |
149 | +socket_split_dir = FALSE |
||
3 | magnus | 150 | |
23 | magnus | 151 | # Name of Unix domain socket (in $socket_dir) used for initial handshake |
152 | # between prayer and prayer-session processes when a user logs in |
||
86 | magnus | 153 | @@ -436,7 +427,7 @@ ssl_session_dir = "$var_prefix/ssl_s |
71 | magnus | 154 | tmp_dir = "$var_prefix/tmp" |
3 | magnus | 155 | |
156 | # Location for PID files for prayer and prayer-session master processes. |
||
157 | -pid_dir = "$var_prefix/pid" |
||
23 | magnus | 158 | +pid_dir = "$var_prefix" |
3 | magnus | 159 | |
160 | # Interface to Hermes finger database |
||
161 | #lookup_rpasswd = "/data/finger/rpasswd.cdb" |
||
86 | magnus | 162 | @@ -454,7 +445,7 @@ pid_dir = "$var_prefix/pid" |
163 | # Template stuff |
||
164 | |||
165 | template_path = "__PREFIX__/templates" |
||
166 | -template_set = "cam" |
||
167 | +template_set = "old" |
||
168 | template_use_compiled = TRUE |
||
169 | |||
170 | template old "Traditional" |
||
171 | @@ -603,14 +594,14 @@ hiersep = "/" |
||
35 | magnus | 172 | dualuse = FALSE |
173 | |||
174 | # Names of postponed_folder and sent_mail_folder, relative to maildir |
||
175 | -postponed_folder = "postponed-msgs" |
||
176 | -sent_mail_folder = "sent-mail" |
||
177 | +postponed_folder = "Drafts" |
||
178 | +sent_mail_folder = "Sent" |
||
179 | |||
180 | # Default domain for outgoing mail. Defaults to "$hostname". |
||
3 | magnus | 181 | # default_domain = "<valid mail domain>" |
182 | |||
183 | # Language for ispell. |
||
184 | -ispell_language = "british" |
||
185 | +ispell_language = "american" |
||
186 | |||
187 | # Size of small and large compose windows |
||
188 | small_cols = 80 |
||
94 | magnus | 189 | --- a/shared/config.c |
190 | +++ b/shared/config.c |
||
191 | @@ -167,7 +167,7 @@ struct config *config_create(void) |
||
192 | config->fatal_dump_core = NIL; |
||
193 | |||
194 | config->template_path = "../templates"; |
||
195 | - config->template_set = "xhtml_strict"; |
||
196 | + config->template_set = "old"; |
||
197 | config->template_use_compiled = T; |
||
198 | config->template_list = NIL; |
||
199 |