Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 44 | Rev 49 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
12 magnus 1
--- a/files/etc/prayer-accountd.cf
2
+++ b/files/etc/prayer-accountd.cf
15 magnus 3
@@ -8,6 +8,10 @@
3 magnus 4
 # Default accountd.cf file suitable for RedHat Linux only.
5
 # See distribution for some sample files for FreeBSD and Solaris
6
 
7
+accountd_port = 145
8
+
15 magnus 9
+authtype = pam
10
+
3 magnus 11
 msforward_name      = ".MSforward"
12
 forward_name        = ".forward"
13
 aliases_name        = "vacation.aliases"
12 magnus 14
--- a/files/Makefile
15
+++ b/files/Makefile
48 magnus 16
@@ -65,21 +65,17 @@ install-aconfig:
3 magnus 17
 
18
 install-motd:
19
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
20
-       etc/motd.html ${BROOT}${PREFIX}/etc
23 magnus 21
+       etc/motd.html ${BROOT}/etc/prayer
3 magnus 22
 
23
 install:
44 magnus 24
-       PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \
25
-       RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \
26
-       RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \
27
-       PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \
28
-       PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \
29
-       PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \
30
-       BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
31
-       ./install.sh
32
-       if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
23 magnus 33
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX}
34
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer
3 magnus 35
+
44 magnus 36
+       tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x
23 magnus 37
        if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
38
        if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
3 magnus 39
-       if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
23 magnus 40
+       if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi
41
+       if [ ! -f $(BROOT)/etc/prayer/welcome.html ]; then $(MAKE) install-welcome; fi
3 magnus 42
 
43
 redhat-install-init.d:
44
        install -D -o root -g root -m 755 \
12 magnus 45
--- a/files/etc/prayer.cf.SRC
46
+++ b/files/etc/prayer.cf.SRC
5 magnus 47
@@ -20,7 +20,7 @@ var_prefix  = "__VAR_PREFIX__"
3 magnus 48
 # User ID to run as if we start off as root
49
 prayer_user           = "prayer"
50
 # Group ID to run as if we start off as root
51
-prayer_group          = "prayer"
52
+prayer_group          = "nogroup"
53
 
54
 # Run prayer as background process.
55
 #   TRUE => will return as soon as valid configuration is found.
48 magnus 56
@@ -266,11 +266,11 @@ http_icon_embed   = TRUE
3 magnus 57
 
35 magnus 58
 # Locatation of SSL certificate file (only used if SSL ports defined).
59
 # Required if we are going to provide SSL services.
60
-ssl_cert_file       = "$prefix/certs/prayer.pem"
61
+ssl_cert_file       = "/etc/ssl/certs/ssl-cert-snakeoil.pem"
62
 
63
 # Locatation of SSL private key file (only used if SSL ports defined).
64
 # Required if we are going to provide SSL services.
65
-ssl_privatekey_file = "$prefix/certs/prayer.pem"
66
+ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key"
67
 
68
 # Master server will regenerate shared RSA key at this interval:
69
 ssl_rsakey_lifespan = 15m
48 magnus 70
@@ -278,26 +278,14 @@ ssl_rsakey_lifespan = 15m
35 magnus 71
 # RSA key remains fresh in child process for this long after first actual use.
72
 ssl_rsakey_freshen  = 15m
73
 
74
-# SSL session cache timeout.
75
-ssl_session_timeout = 24h
76
+# SSL session cache timeout. Uncomment to enable SSL session caching.
77
+# You should also arrange for prayer-ssl-prune to be run periodically.
78
+#ssl_session_timeout = 24h
79
 
80
 # EGD socket, if system has no /dev/urandom
81
 #egd_socket = "/var/prngd/urandom"
82
 
83
 ######################################################################
84
-
85
-# Direct connection stuff. Experimental! Leave this well alone unless you
86
-# understand what it is for (DESIGN document provides detail for the curious).
87
-direct_enable       = FALSE
88
-
89
-# Following four options just define a set of (non-overlapping) ports for
90
-# SSL and plaintext use if direct connection mode is enabled.
91
-direct_ssl_first    = 5000
92
-direct_ssl_count    = 1000
93
-direct_plain_first  = 4000
94
-direct_plain_count  = 1000
95
-
96
-######################################################################
97
 # Session specific configuration
98
 
99
 # Session switches to idle mode after this much time: connections to IMAP
48 magnus 100
@@ -382,13 +370,13 @@ ispell_path         = /usr/bin/ispell
35 magnus 101
 #  <login_suffix_path>
102
 
103
 # Login page prefix
104
-#login_prefix_path   = "$prefix/etc/login_prefix.html"
105
+#login_prefix_path   = "/etc/login_prefix.html"
106
 
107
 # Message of the day file
108
-#motd_path           = "$prefix/etc/motd.html"
109
+#motd_path           = "/etc/motd.html"
110
 
111
 # Login page suffix
112
-#login_suffix_path   = "$prefix/etc/login_suffix.html"
113
+#login_suffix_path   = "/etc/login_suffix.html"
114
 
115
 # Login security: Prayer's front page defaults to a login form.
116
 # If the user does not connect via SSL then this can be changed
48 magnus 117
@@ -423,10 +411,7 @@ bin_dir             = "__BIN_DIR__"
35 magnus 118
 
3 magnus 119
 # Various directories used by the running system
120
 # Logs stored in $log_dir
121
-log_dir             = "$var_prefix/logs"
35 magnus 122
-
123
-# $lock_dir used for interlocking between prayer processes
3 magnus 124
-lock_dir            = "$var_prefix/locks"
48 magnus 125
+log_dir             = "/var/log/prayer"
3 magnus 126
 
127
 # $socket_dir is location for unix domain sockets which connect frontend
128
 # to backend in proxy mode of operation.
48 magnus 129
@@ -434,7 +419,7 @@ socket_dir          = "$var_prefix/socke
3 magnus 130
 
131
 # Split socket directory into 64 subdirs keyed on first letter of sessionID
132
 # Code provides compatibility in both directions: can switch back and forward
23 magnus 133
-socket_split_dir    = TRUE
134
+socket_split_dir    = FALSE
3 magnus 135
 
23 magnus 136
 # Name of Unix domain socket (in $socket_dir) used for initial handshake
137
 # between prayer and prayer-session processes when a user logs in
48 magnus 138
@@ -445,10 +430,10 @@ ssl_session_dir     = "$var_prefix/ssl_s
3 magnus 139
 
140
 # Location for temporary files e.g; attachments and folders in transist
141
 # during upload and download operation. Core files also end up here
142
-tmp_dir             = "$var_prefix/tmp"
143
+tmp_dir             = "/tmp"
144
 
145
 # Location for PID files for prayer and prayer-session master processes.
146
-pid_dir             = "$var_prefix/pid"
23 magnus 147
+pid_dir             = "$var_prefix"
3 magnus 148
 
149
 # Interface to Hermes finger database
150
 #lookup_rpasswd   = "/data/finger/rpasswd.cdb"
48 magnus 151
@@ -609,14 +594,14 @@ hiersep             = "/"
35 magnus 152
 dualuse             = FALSE
153
 
154
 # Names of postponed_folder and sent_mail_folder, relative to maildir
155
-postponed_folder    = "postponed-msgs"
156
-sent_mail_folder    = "sent-mail"
157
+postponed_folder    = "Drafts"
158
+sent_mail_folder    = "Sent"
159
 
160
 # Default domain for outgoing mail. Defaults to "$hostname".
3 magnus 161
 # default_domain      = "<valid mail domain>"
162
 
163
 # Language for ispell.
164
-ispell_language     = "british"
165
+ispell_language     = "american"
166
 
167
 # Size of small and large compose windows
168
 small_cols          = 80