Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 71 | Rev 80 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
12 magnus 1
--- a/files/etc/prayer-accountd.cf
2
+++ b/files/etc/prayer-accountd.cf
15 magnus 3
@@ -8,6 +8,10 @@
3 magnus 4
 # Default accountd.cf file suitable for RedHat Linux only.
5
 # See distribution for some sample files for FreeBSD and Solaris
6
 
7
+accountd_port = 145
8
+
15 magnus 9
+authtype = pam
10
+
3 magnus 11
 msforward_name      = ".MSforward"
12
 forward_name        = ".forward"
13
 aliases_name        = "vacation.aliases"
12 magnus 14
--- a/files/Makefile
15
+++ b/files/Makefile
49 magnus 16
@@ -65,21 +65,16 @@ install-aconfig:
3 magnus 17
 
18
 install-motd:
19
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
20
-       etc/motd.html ${BROOT}${PREFIX}/etc
23 magnus 21
+       etc/motd.html ${BROOT}/etc/prayer
3 magnus 22
 
23
 install:
44 magnus 24
-       PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \
25
-       RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \
26
-       RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \
27
-       PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \
28
-       PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \
29
-       PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \
30
-       BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
31
-       ./install.sh
32
-       if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
23 magnus 33
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX}
34
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer
3 magnus 35
+
44 magnus 36
+       tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x
23 magnus 37
        if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
38
        if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
3 magnus 39
-       if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
23 magnus 40
+       if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi
3 magnus 41
 
42
 redhat-install-init.d:
43
        install -D -o root -g root -m 755 \
12 magnus 44
--- a/files/etc/prayer.cf.SRC
45
+++ b/files/etc/prayer.cf.SRC
5 magnus 46
@@ -20,7 +20,7 @@ var_prefix  = "__VAR_PREFIX__"
3 magnus 47
 # User ID to run as if we start off as root
48
 prayer_user           = "prayer"
49
 # Group ID to run as if we start off as root
50
-prayer_group          = "prayer"
51
+prayer_group          = "nogroup"
52
 
53
 # Run prayer as background process.
54
 #   TRUE => will return as soon as valid configuration is found.
48 magnus 55
@@ -266,11 +266,11 @@ http_icon_embed   = TRUE
3 magnus 56
 
35 magnus 57
 # Locatation of SSL certificate file (only used if SSL ports defined).
58
 # Required if we are going to provide SSL services.
59
-ssl_cert_file       = "$prefix/certs/prayer.pem"
60
+ssl_cert_file       = "/etc/ssl/certs/ssl-cert-snakeoil.pem"
61
 
62
 # Locatation of SSL private key file (only used if SSL ports defined).
63
 # Required if we are going to provide SSL services.
64
-ssl_privatekey_file = "$prefix/certs/prayer.pem"
65
+ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key"
66
 
67
 # Master server will regenerate shared RSA key at this interval:
68
 ssl_rsakey_lifespan = 15m
48 magnus 69
@@ -278,26 +278,14 @@ ssl_rsakey_lifespan = 15m
35 magnus 70
 # RSA key remains fresh in child process for this long after first actual use.
71
 ssl_rsakey_freshen  = 15m
72
 
73
-# SSL session cache timeout.
74
-ssl_session_timeout = 24h
75
+# SSL session cache timeout. Uncomment to enable SSL session caching.
76
+# You should also arrange for prayer-ssl-prune to be run periodically.
77
+#ssl_session_timeout = 24h
78
 
79
 # EGD socket, if system has no /dev/urandom
80
 #egd_socket = "/var/prngd/urandom"
81
 
82
 ######################################################################
83
-
84
-# Direct connection stuff. Experimental! Leave this well alone unless you
85
-# understand what it is for (DESIGN document provides detail for the curious).
86
-direct_enable       = FALSE
87
-
88
-# Following four options just define a set of (non-overlapping) ports for
89
-# SSL and plaintext use if direct connection mode is enabled.
90
-direct_ssl_first    = 5000
91
-direct_ssl_count    = 1000
92
-direct_plain_first  = 4000
93
-direct_plain_count  = 1000
94
-
95
-######################################################################
96
 # Session specific configuration
97
 
98
 # Session switches to idle mode after this much time: connections to IMAP
48 magnus 99
@@ -382,13 +370,13 @@ ispell_path         = /usr/bin/ispell
35 magnus 100
 #  <login_suffix_path>
101
 
102
 # Login page prefix
103
-#login_prefix_path   = "$prefix/etc/login_prefix.html"
104
+#login_prefix_path   = "/etc/login_prefix.html"
105
 
106
 # Message of the day file
107
-#motd_path           = "$prefix/etc/motd.html"
79 magnus 108
+#motd_path           = "/etc/prayer/motd.html"
35 magnus 109
 
110
 # Login page suffix
111
-#login_suffix_path   = "$prefix/etc/login_suffix.html"
112
+#login_suffix_path   = "/etc/login_suffix.html"
113
 
114
 # Login security: Prayer's front page defaults to a login form.
115
 # If the user does not connect via SSL then this can be changed
79 magnus 116
@@ -409,9 +397,6 @@ ssl_required        = FALSE
117
 # Session banner (local HTML inserted into each page of login session)
118
 #session_banner_path = "$prefix/etc/session_banner.html"
35 magnus 119
 
79 magnus 120
-# Location of help files
121
-help_dir            = "$prefix/help"
122
-
123
 # Location of icon files
124
 icon_dir            = "$prefix/icons"
125
 
126
@@ -423,10 +408,11 @@ bin_dir             = "__BIN_DIR__"
127
 
3 magnus 128
 # Various directories used by the running system
129
 # Logs stored in $log_dir
130
-log_dir             = "$var_prefix/logs"
48 magnus 131
+log_dir             = "/var/log/prayer"
3 magnus 132
 
79 magnus 133
 # $lock_dir used for interlocking between prayer processes
134
-lock_dir            = "$var_prefix/locks"
135
+# (only on Debian GNU/kFreeBSD)
136
+lock_dir            = "$var_prefix"
137
 
3 magnus 138
 # $socket_dir is location for unix domain sockets which connect frontend
139
 # to backend in proxy mode of operation.
79 magnus 140
@@ -434,7 +420,7 @@ socket_dir          = "$var_prefix/socke
3 magnus 141
 
142
 # Split socket directory into 64 subdirs keyed on first letter of sessionID
143
 # Code provides compatibility in both directions: can switch back and forward
23 magnus 144
-socket_split_dir    = TRUE
145
+socket_split_dir    = FALSE
3 magnus 146
 
23 magnus 147
 # Name of Unix domain socket (in $socket_dir) used for initial handshake
148
 # between prayer and prayer-session processes when a user logs in
79 magnus 149
@@ -448,7 +434,7 @@ ssl_session_dir     = "$var_prefix/ssl_s
71 magnus 150
 tmp_dir             = "$var_prefix/tmp"
3 magnus 151
 
152
 # Location for PID files for prayer and prayer-session master processes.
153
-pid_dir             = "$var_prefix/pid"
23 magnus 154
+pid_dir             = "$var_prefix"
3 magnus 155
 
156
 # Interface to Hermes finger database
157
 #lookup_rpasswd   = "/data/finger/rpasswd.cdb"
79 magnus 158
@@ -609,14 +595,14 @@ hiersep             = "/"
35 magnus 159
 dualuse             = FALSE
160
 
161
 # Names of postponed_folder and sent_mail_folder, relative to maildir
162
-postponed_folder    = "postponed-msgs"
163
-sent_mail_folder    = "sent-mail"
164
+postponed_folder    = "Drafts"
165
+sent_mail_folder    = "Sent"
166
 
167
 # Default domain for outgoing mail. Defaults to "$hostname".
3 magnus 168
 # default_domain      = "<valid mail domain>"
169
 
170
 # Language for ispell.
171
-ispell_language     = "british"
172
+ispell_language     = "american"
173
 
174
 # Size of small and large compose windows
175
 small_cols          = 80
71 magnus 176
--- a/shared/config.c
177
+++ b/shared/config.c
79 magnus 178
@@ -2139,12 +2139,10 @@ BOOL config_check(struct config * config
179
     struct config_http_port *chp;
180
     char hostname[MAX_ADDRESS+1], domainname[MAX_ADDRESS+1];
181
 
182
-    TEST_STRING(config->help_dir, "help_dir");
183
     TEST_STRING(config->icon_dir, "icon_dir");
71 magnus 184
     TEST_STRING(config->socket_dir, "socket_dir");
185
     TEST_STRING(config->init_socket_name, "init_socket_name");
186
     TEST_STRING(config->ssl_session_dir, "ssl_session_dir");
187
-    TEST_STRING(config->lock_dir, "lock_dir");
188
     TEST_STRING(config->log_dir, "log_dir");
189
     TEST_STRING(config->tmp_dir, "tmp_dir");
190
     TEST_STRING(config->pid_dir, "pid_dir");