Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
123 | magnus | 1 | --- a/lib/mydb_db3.c |
2 | +++ b/lib/mydb_db3.c |
||
3 | @@ -190,21 +190,10 @@ static int myinit(const char *dbdir, int |
||
4 | |||
5 | static int init(const char *dbdir, int myflags) |
||
6 | { |
||
7 | - int maj, min, patch; |
||
8 | - char *vstr; |
||
9 | int r; |
||
10 | |||
11 | if (dbinit++) return 0; |
||
12 | |||
13 | - vstr = db_version(&maj, &min, &patch); |
||
14 | - if (maj != DB_VERSION_MAJOR || min != DB_VERSION_MINOR || |
||
15 | - DB_VERSION_PATCH > patch) { |
||
16 | - log_fatal("incorrect version of Berkeley db: " |
||
17 | - "compiled against %d.%d.%d, linked against %d.%d.%d", |
||
18 | - DB_VERSION_MAJOR, DB_VERSION_MINOR, DB_VERSION_PATCH, |
||
19 | - maj, min, patch); |
||
20 | - } |
||
21 | - |
||
22 | if (!(r = myinit(dbdir, myflags))) |
||
23 | return(0); |
||
24 |