Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
178 magnus 1
Description: Add extern to struct declarations in template indices.
2
Bug-Debian: https://bugs.debian.org/957707
3
 
4
--- a/templates/src/build_index.pl
5
+++ b/templates/src/build_index.pl
6
@@ -23,7 +23,7 @@ print <<'EOM';
7
 EOM
8
 
9
 foreach $i (@templates) {
10
-  print "struct template _template_${prefix}_${i};\n";
11
+  print "extern struct template _template_${prefix}_${i};\n";
12
 }
13
 
14
 print <<"EOM";