Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
132 | magnus | 1 | --- a/accountd/filter.c |
2 | +++ b/accountd/filter.c |
||
3 | @@ -266,7 +266,6 @@ filter_print_vacation(struct config *con |
||
4 | |||
5 | fprintf(file, "# MSshell :: vacation\n"); |
||
6 | fprintf(file, "if personal\n"); |
||
7 | - fprintf(file, " alias %s@cam.ac.uk\n", pwd->pw_name); |
||
8 | |||
9 | if (!filter_print_aliases(config, file)) |
||
10 | return (NIL); |
||
11 | @@ -278,7 +277,7 @@ filter_print_vacation(struct config *con |
||
12 | fprintf(file, ("This message is automatically generated " |
||
13 | "in response to your mail\\n\\" "\n")); |
||
14 | fprintf(file, ("message (perhaps re-directed) to " |
||
15 | - "$local_part@hermes.cam.ac.uk.\\n\\n\"\n")); |
||
16 | + "$local_part@$local_domain.\\n\\n\"\n")); |
||
17 | fprintf(file, " file ${home}/vacation.message\n"); |
||
18 | fprintf(file, " log ${home}/vacation.log\n"); |
||
19 | fprintf(file, " once ${home}/vacation.once\n"); |
||
20 | @@ -307,10 +306,10 @@ filter_print_spam(struct config *config, |
||
21 | threshold = atoi(filter->threshold); |
||
22 | |||
23 | /* XXX (threshold == 0) okay? */ |
||
24 | - fprintf(file, "if $h_X-Cam-SpamScore contains \""); |
||
25 | + fprintf(file, "if $h_X-Spam-Level contains \""); |
||
26 | |||
27 | for (i=0 ; i < threshold; i++) |
||
28 | - fputc('s', file); |
||
29 | + fputc('*', file); |
||
30 | |||
31 | fprintf(file, "\" then\n"); |
||
32 | fprintf(file, " save mail/spam\n"); |