Rev 23 | Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | #!/usr/bin/make -f |
2 | # Sample debian/rules that uses cdbs. Originaly written by Robert Millan. |
||
3 | # This file is public domain. |
||
4 | |||
5 | DEB_AUTO_CLEANUP_RCS := yes |
||
6 | |||
7 | # Add here any variable or target overrides you need |
||
8 | |||
9 | makebuilddir/prayer:: |
||
10 | cp debian/Config . |
||
11 | |||
12 | include /usr/share/cdbs/1/class/makefile.mk |
||
13 | include /usr/share/cdbs/1/rules/debhelper.mk |
||
14 | include /usr/share/cdbs/1/rules/patchsys-quilt.mk |
||
15 | |||
16 | #DEB_MAKE_INVOKE = $(DEB_MAKE_ENVVARS) make |
||
17 | DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/tmp |
||
18 | DEB_INSTALL_CHANGELOGS_ALL = docs/DONE |
||
19 | DEB_INSTALL_DOCS_ALL = -XCVS |
||
20 | DEB_DH_INSTALL_ARGS = -XCVS |
||
21 | DEB_DH_INSTALL_SOURCEDIR = debian/tmp |
||
22 | |||
23 | clean:: |
||
24 | rm -f Config |