Subversion Repositories prayer

Compare Revisions

Ignore whitespace Rev 106 → Rev 107

/trunk/debian/patches/dlopen_templates.patch
44,10 → 44,14
+struct template_map_index *dlopen_templates(const char *set, const char *suffix);
--- a/templates/cam/Makefile
+++ b/templates/cam/Makefile
@@ -8,10 +8,14 @@ endif
@@ -6,12 +6,16 @@ else
include ../../Config
endif
CFLAGS = $(BASECFLAGS)
LDFLAGS = $(BASELDFLAGS)
-CFLAGS = $(BASECFLAGS)
-LDFLAGS = $(BASELDFLAGS)
+CFLAGS = $(BASECFLAGS) -fPIC
+LDFLAGS = $(BASELDFLAGS) -fPIC
+LDFLAGS_TEMPLATELIB = \
+ -Wl,--defsym=template_map=template_map_$(TYPE) \
+ -Wl,--defsym=template_map_count=template_map_$(TYPE)_count
86,10 → 90,14
--- a/templates/old/Makefile
+++ b/templates/old/Makefile
@@ -8,10 +8,14 @@ endif
@@ -6,12 +6,16 @@ else
include ../../Config
endif
CFLAGS = $(BASECFLAGS)
LDFLAGS = $(BASELDFLAGS)
-CFLAGS = $(BASECFLAGS)
-LDFLAGS = $(BASELDFLAGS)
+CFLAGS = $(BASECFLAGS) -fPIC
+LDFLAGS = $(BASELDFLAGS) -fPIC
+LDFLAGS_TEMPLATELIB = \
+ -Wl,--defsym=template_map=template_map_$(TYPE) \
+ -Wl,--defsym=template_map_count=template_map_$(TYPE)_count