Subversion Repositories prayer

Compare Revisions

Ignore whitespace Rev 85 → Rev 86

/trunk/debian/patches/makefile_install_config.patch
13,7 → 13,7
aliases_name = "vacation.aliases"
--- a/files/Makefile
+++ b/files/Makefile
@@ -65,21 +65,16 @@ install-aconfig:
@@ -66,21 +66,16 @@ install-aconfig:
install-motd:
$(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
61,7 → 61,7
# Name of Prayer user preferences file on IMAP server
prefs_folder_name = ".prayer"
@@ -266,11 +266,11 @@ http_icon_embed = TRUE
@@ -270,11 +270,11 @@ icon_expire_timeout = 7d
# Locatation of SSL certificate file (only used if SSL ports defined).
# Required if we are going to provide SSL services.
75,7 → 75,7
# Master server will regenerate shared RSA key at this interval:
ssl_rsakey_lifespan = 15m
@@ -278,26 +278,14 @@ ssl_rsakey_lifespan = 15m
@@ -282,26 +282,14 @@ ssl_rsakey_lifespan = 15m
# RSA key remains fresh in child process for this long after first actual use.
ssl_rsakey_freshen = 15m
105,35 → 105,30
# Session specific configuration
# Session switches to idle mode after this much time: connections to IMAP
@@ -382,13 +370,13 @@ ispell_path = /usr/bin/ispell
# <login_suffix_path>
@@ -376,13 +364,15 @@ sendmail_path = /usr/lib/sendmail
ispell_path = /usr/bin/ispell
# Login page prefix
-#login_prefix_path = "$prefix/etc/login_prefix.html"
+#login_prefix_path = "/etc/login_prefix.html"
# Message of the day file
-#motd_path = "$prefix/etc/motd.html"
-motd_path = "$prefix/etc/motd.html"
-
-# HTML to insert into login page
-#login_insert1_path = "$prefix/etc/ucsnews.html"
+#motd_path = "/etc/prayer/motd.html"
# Login page suffix
-#login_suffix_path = "$prefix/etc/login_suffix.html"
+#login_suffix_path = "/etc/login_suffix.html"
-# HTML to insert into login page
-#login_insert2_path = "$prefix/etc/ucsnews.html"
+# HTML to make available to login template as $login_insert1
+# (only used in "cam" template set).
+#login_insert1_path = "/etc/prayer/login1.html"
+
+# HTML to make available to login template as $login_insert2
+# (currently not used in any template set).
+#login_insert2_path = "/etc/prayer/login2.html"
# Login security: Prayer's front page defaults to a login form.
# If the user does not connect via SSL then this can be changed
@@ -409,9 +397,6 @@ ssl_required = FALSE
# Session banner (local HTML inserted into each page of login session)
#session_banner_path = "$prefix/etc/session_banner.html"
@@ -411,10 +401,11 @@ bin_dir = "__BIN_DIR__"
-# Location of help files
-help_dir = "$prefix/help"
-
# Location of icon files
icon_dir = "$prefix/icons"
@@ -423,10 +408,11 @@ bin_dir = "__BIN_DIR__"
# Various directories used by the running system
# Logs stored in $log_dir
-log_dir = "$var_prefix/logs"
146,7 → 141,7
# $socket_dir is location for unix domain sockets which connect frontend
# to backend in proxy mode of operation.
@@ -434,7 +420,7 @@ socket_dir = "$var_prefix/socke
@@ -422,7 +413,7 @@ socket_dir = "$var_prefix/socke
# Split socket directory into 64 subdirs keyed on first letter of sessionID
# Code provides compatibility in both directions: can switch back and forward
155,7 → 150,7
# Name of Unix domain socket (in $socket_dir) used for initial handshake
# between prayer and prayer-session processes when a user logs in
@@ -448,7 +434,7 @@ ssl_session_dir = "$var_prefix/ssl_s
@@ -436,7 +427,7 @@ ssl_session_dir = "$var_prefix/ssl_s
tmp_dir = "$var_prefix/tmp"
# Location for PID files for prayer and prayer-session master processes.
164,7 → 159,16
# Interface to Hermes finger database
#lookup_rpasswd = "/data/finger/rpasswd.cdb"
@@ -609,14 +595,14 @@ hiersep = "/"
@@ -454,7 +445,7 @@ pid_dir = "$var_prefix/pid"
# Template stuff
template_path = "__PREFIX__/templates"
-template_set = "cam"
+template_set = "old"
template_use_compiled = TRUE
template old "Traditional"
@@ -603,14 +594,14 @@ hiersep = "/"
dualuse = FALSE
# Names of postponed_folder and sent_mail_folder, relative to maildir
182,18 → 186,3
# Size of small and large compose windows
small_cols = 80
--- a/shared/config.c
+++ b/shared/config.c
@@ -2139,12 +2139,10 @@ BOOL config_check(struct config * config
struct config_http_port *chp;
char hostname[MAX_ADDRESS+1], domainname[MAX_ADDRESS+1];
- TEST_STRING(config->help_dir, "help_dir");
TEST_STRING(config->icon_dir, "icon_dir");
TEST_STRING(config->socket_dir, "socket_dir");
TEST_STRING(config->init_socket_name, "init_socket_name");
TEST_STRING(config->ssl_session_dir, "ssl_session_dir");
- TEST_STRING(config->lock_dir, "lock_dir");
TEST_STRING(config->log_dir, "log_dir");
TEST_STRING(config->tmp_dir, "tmp_dir");
TEST_STRING(config->pid_dir, "pid_dir");