Subversion Repositories prayer

Compare Revisions

Ignore whitespace Rev 106 → Rev 107

/trunk/debian/patches/template_sdk.patch
88,13 → 88,14
+print "$name$suffix.so:", "_template_index$suffix.o", map {"$_.o"} @all;
--- /dev/null
+++ b/templates/src/template-set.make.in
@@ -0,0 +1,66 @@
@@ -0,0 +1,67 @@
+ifndef NAME
+NAME := $(notdir $(CURDIR))
+endif
+
+CPPFLAGS = -I/usr/include/prayer
+LDFLAGS_TEMPLATELIB = -shared \
+CFLAGS += -fPIC
+LDFLAGS_TEMPLATELIB = -shared -fPIC \
+ -Wl,--defsym=template_map=template_map_$(NAME) \
+ -Wl,--defsym=template_map_count=template_map_$(NAME)_count
+