Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | #!/bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 20_about_close.dpatch by Magnus Holmgren <magnus@kibibyte.se> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Make the Close button in the About dialog work |
||
6 | |||
7 | @DPATCH@ |
||
8 | diff -urNad trunk~/pyscrabble/gtkutil.py trunk/pyscrabble/gtkutil.py |
||
9 | --- trunk~/pyscrabble/gtkutil.py 2006-12-05 15:49:00.000000000 +0100 |
||
10 | +++ trunk/pyscrabble/gtkutil.py 2007-10-03 16:30:51.000000000 +0200 |
||
11 | @@ -73,6 +73,7 @@ |
||
12 | dialog.set_translator_credits(_('translator-credits')) |
||
13 | gtk.about_dialog_set_url_hook(util.showUrl, data=constants.ONLINE_SITE) |
||
14 | dialog.set_version(constants.VERSION) |
||
15 | + dialog.connect("response", lambda d, r: d.destroy()) |
||
16 | dialog.show() |
||
17 | |||
18 | def getSelectedItem(view, col): |