?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Go to most recent revision |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
#!/bin/sh /usr/share/dpatch/dpatch-run
## 20_about_close.dpatch by Magnus Holmgren <magnus@kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Make the Close button in the About dialog work
@DPATCH@
diff -urNad trunk~/pyscrabble/gtkutil.py trunk/pyscrabble/gtkutil.py
--- trunk~/pyscrabble/gtkutil.py 2006-12-05 15:49:00.000000000 +0100
+++ trunk/pyscrabble/gtkutil.py 2007-10-03 16:30:51.000000000 +0200
@@ -73,6 +73,7 @@
dialog.set_translator_credits(_('translator-credits'))
gtk.about_dialog_set_url_hook(util.showUrl, data=constants.ONLINE_SITE)
dialog.set_version(constants.VERSION)
+ dialog.connect("response", lambda d, r: d.destroy())
dialog.show()
def getSelectedItem(view, col):