Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 20 | Rev 27 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 20 Rev 23
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
DESTDIR=$(CURDIR)/debian/tmp
12
DESTDIR=$(CURDIR)/debian/tmp
13
ICON_SIZES=16 22 32 48 64 96
13
ICON_SIZES=16 22 32 48 64 96
14
PIXMAP_SIZES=16 32
14
PIXMAP_SIZES=16 32
15
15
16
include /usr/share/dpatch/dpatch.make
16
include /usr/share/dpatch/dpatch.make
17
17
18
clean: clean-patched unpatch
18
unpatch: clean-patched
-
 
19
clean: unpatch
19
	dh_clean
20
	dh_clean
20
21
21
clean-patched: patch-stamp
22
clean-patched: patch-stamp
22
	dh_testdir
23
	dh_testdir
23
	dh_testroot
24
	dh_testroot
24
	rm -f build-stamp
25
	rm -f build-stamp
25
	rm -f pyscrabble-*.png pyscrabble-*.xpm
26
	rm -f pyscrabble-*.png pyscrabble-*.xpm
26
27
27
	python setup.py clean -a
28
	python setup.py clean -a
28
	find -name '*.pyc' -delete
29
	find -name '*.pyc' -delete
29
30
30
build: patch-stamp
31
build: build-stamp
-
 
32
build-stamp: patch-stamp
31
	python setup.py build
33
	python setup.py build
32
34
33
	for size in $(ICON_SIZES); do \
35
	for size in $(ICON_SIZES); do \
34
		rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \
36
		rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \
35
	done
37
	done
36
	for size in $(PIXMAP_SIZES); do \
38
	for size in $(PIXMAP_SIZES); do \
37
		convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \
39
		convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \
38
	done
40
	done
-
 
41
	touch "$@"
39
42
40
install: build
43
install: build
41
	dh_testdir
44
	dh_testdir
42
	dh_testroot
45
	dh_testroot
43
	dh_clean -k 
46
	dh_clean -k 
44
47
45
	python setup.py install --no-compile --root=$(DESTDIR) \
48
	python setup.py install --no-compile --root=$(DESTDIR) \
46
		--prefix=/usr \
49
		--prefix=/usr \
47
		--install-scripts=/usr/games \
50
		--install-scripts=/usr/games \
48
		--confdir=/etc/pyscrabble \
51
		--confdir=/etc/pyscrabble \
49
		--logdir=/var/log/pyscrabble \
52
		--logdir=/var/log/pyscrabble \
50
		--dbdir=/var/lib/pyscrabble
53
		--dbdir=/var/lib/pyscrabble
51
	install -m755 -d $(DESTDIR)/usr/sbin
54
	install -m755 -d $(DESTDIR)/usr/sbin
52
	mv $(DESTDIR)/usr/games/pyscrabble-main.py $(DESTDIR)/usr/games/pyscrabble
55
	mv $(DESTDIR)/usr/games/pyscrabble-main.py $(DESTDIR)/usr/games/pyscrabble
53
	mv $(DESTDIR)/usr/games/server_console.py $(DESTDIR)/usr/sbin/pyscrabble-server
56
	mv $(DESTDIR)/usr/games/server_console.py $(DESTDIR)/usr/sbin/pyscrabble-server
54
#	rm $(DESTDIR)/usr/bin/db_upgrade.py
57
#	rm $(DESTDIR)/usr/bin/db_upgrade.py
55
	install -m755 -d $(DESTDIR)/usr/share/pixmaps
58
	install -m755 -d $(DESTDIR)/usr/share/pixmaps
56
	install -m644 pyscrabble-*.xpm $(DESTDIR)/usr/share/pixmaps
59
	install -m644 pyscrabble-*.xpm $(DESTDIR)/usr/share/pixmaps
57
	install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/scalable/apps
60
	install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/scalable/apps
58
	gzip < debian/pyscrabble.svg > $(DESTDIR)/usr/share/icons/hicolor/scalable/apps/pyscrabble.svgz
61
	gzip < debian/pyscrabble.svg > $(DESTDIR)/usr/share/icons/hicolor/scalable/apps/pyscrabble.svgz
59
	for size in $(ICON_SIZES); do \
62
	for size in $(ICON_SIZES); do \
60
		install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; \
63
		install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; \
61
		install -m644 pyscrabble-$$size.png \
64
		install -m644 pyscrabble-$$size.png \
62
			$(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/pyscrabble.png; \
65
			$(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/pyscrabble.png; \
63
	done
66
	done
64
	install -d -m755 $(DESTDIR)/usr/share/applications/
67
	install -d -m755 $(DESTDIR)/usr/share/applications/
65
	install -m644 debian/pyscrabble.desktop $(DESTDIR)/usr/share/applications/
68
	install -m644 debian/pyscrabble.desktop $(DESTDIR)/usr/share/applications/
66
69
67
70
68
71
69
# Build architecture-dependent files here.
72
# Build architecture-dependent files here.
70
binary-arch:
73
binary-arch:
71
# We have nothing to do by default.
74
# We have nothing to do by default.
72
75
73
# Build architecture-independent files here.
76
# Build architecture-independent files here.
74
binary-indep: build install
77
binary-indep: build install
75
	dh_testdir
78
	dh_testdir
76
	dh_testroot
79
	dh_testroot
77
	dh_install --sourcedir=debian/tmp
80
	dh_install --sourcedir=debian/tmp
78
	dh_link
81
	dh_link
79
	dh_pycentral
82
	dh_pycentral
80
	dh_installchangelogs CHANGELOG.txt
83
	dh_installchangelogs CHANGELOG.txt
81
	dh_installdocs
84
	dh_installdocs
82
	dh_installexamples
85
	dh_installexamples
83
	dh_installman
86
	dh_installman
84
	dh_installinit -r
87
	dh_installinit -r
85
	dh_installmenu
88
	dh_installmenu
86
	dh_strip
89
	dh_strip
87
	dh_compress
90
	dh_compress
88
	dh_fixperms
91
	dh_fixperms
89
	dh_installdeb
92
	dh_installdeb
90
	dh_shlibdeps
93
	dh_shlibdeps
91
	dh_gencontrol
94
	dh_gencontrol
92
	dh_md5sums
95
	dh_md5sums
93
	dh_builddeb
96
	dh_builddeb
94
97
95
binary: binary-indep binary-arch
98
binary: binary-indep binary-arch
96
.PHONY: build clean binary-indep binary-arch binary install configure
99
.PHONY: build clean binary-indep binary-arch binary install configure