Rev 20 | Rev 27 | Go to most recent revision | Show entire file | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 20 | Rev 23 | ||
---|---|---|---|
Line 13... | Line 13... | ||
13 | ICON_SIZES=16 22 32 48 64 96 |
13 | ICON_SIZES=16 22 32 48 64 96 |
14 | PIXMAP_SIZES=16 32 |
14 | PIXMAP_SIZES=16 32 |
15 | 15 | ||
16 | include /usr/share/dpatch/dpatch.make |
16 | include /usr/share/dpatch/dpatch.make |
17 | 17 | ||
18 | clean: clean-patched unpatch |
18 | unpatch: clean-patched |
- | 19 | clean: unpatch |
|
19 | dh_clean |
20 | dh_clean |
20 | 21 | ||
21 | clean-patched: patch-stamp |
22 | clean-patched: patch-stamp |
22 | dh_testdir |
23 | dh_testdir |
23 | dh_testroot |
24 | dh_testroot |
Line 25... | Line 26... | ||
25 | rm -f pyscrabble-*.png pyscrabble-*.xpm |
26 | rm -f pyscrabble-*.png pyscrabble-*.xpm |
26 | 27 | ||
27 | python setup.py clean -a |
28 | python setup.py clean -a |
28 | find -name '*.pyc' -delete |
29 | find -name '*.pyc' -delete |
29 | 30 | ||
30 | build: patch-stamp |
31 | build: build-stamp |
- | 32 | build-stamp: patch-stamp |
|
31 | python setup.py build |
33 | python setup.py build |
32 | 34 | ||
33 | for size in $(ICON_SIZES); do \ |
35 | for size in $(ICON_SIZES); do \ |
34 | rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \ |
36 | rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \ |
35 | done |
37 | done |
36 | for size in $(PIXMAP_SIZES); do \ |
38 | for size in $(PIXMAP_SIZES); do \ |
37 | convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \ |
39 | convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \ |
38 | done |
40 | done |
- | 41 | touch "$@" |
|
39 | 42 | ||
40 | install: build |
43 | install: build |
41 | dh_testdir |
44 | dh_testdir |
42 | dh_testroot |
45 | dh_testroot |
43 | dh_clean -k |
46 | dh_clean -k |