Rev 29 | Rev 43 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
||
3 | # Sample debian/rules that uses debhelper. |
||
4 | # This file was originally written by Joey Hess and Craig Small. |
||
5 | # As a special exception, when this file is copied by dh-make into a |
||
6 | # dh-make output file, you may use that output file without restriction. |
||
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
||
8 | |||
9 | # Uncomment this to turn on verbose mode. |
||
10 | #export DH_VERBOSE=1 |
||
11 | |||
12 | DESTDIR=$(CURDIR)/debian/tmp |
||
13 | ICON_SIZES=16 22 32 48 64 96 |
||
14 | PIXMAP_SIZES=16 32 |
||
15 | |||
27 | magnus | 16 | clean: |
2 | magnus | 17 | dh_testdir |
18 | dh_testroot |
||
3 | magnus | 19 | rm -f build-stamp |
2 | magnus | 20 | rm -f pyscrabble-*.png pyscrabble-*.xpm |
21 | |||
22 | python setup.py clean -a |
||
23 | find -name '*.pyc' -delete |
||
27 | magnus | 24 | dh_clean |
2 | magnus | 25 | |
23 | magnus | 26 | build: build-stamp |
27 | magnus | 27 | build-stamp: |
2 | magnus | 28 | python setup.py build |
29 | |||
30 | for size in $(ICON_SIZES); do \ |
||
31 | rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \ |
||
32 | done |
||
33 | for size in $(PIXMAP_SIZES); do \ |
||
34 | convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \ |
||
35 | done |
||
23 | magnus | 36 | touch "$@" |
2 | magnus | 37 | |
38 | install: build |
||
39 | dh_testdir |
||
40 | dh_testroot |
||
29 | magnus | 41 | dh_prep |
2 | magnus | 42 | |
43 | python setup.py install --no-compile --root=$(DESTDIR) \ |
||
28 | magnus | 44 | --install-layout=deb \ |
38 | magnus | 45 | --install-scripts=/usr/share/games/pyscrabble/python \ |
46 | --install-lib=/usr/share/games/pyscrabble/python \ |
||
2 | magnus | 47 | --confdir=/etc/pyscrabble \ |
48 | --logdir=/var/log/pyscrabble \ |
||
49 | --dbdir=/var/lib/pyscrabble |
||
18 | magnus | 50 | install -m755 -d $(DESTDIR)/usr/sbin |
2 | magnus | 51 | install -m755 -d $(DESTDIR)/usr/share/pixmaps |
52 | install -m644 pyscrabble-*.xpm $(DESTDIR)/usr/share/pixmaps |
||
53 | install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/scalable/apps |
||
54 | gzip < debian/pyscrabble.svg > $(DESTDIR)/usr/share/icons/hicolor/scalable/apps/pyscrabble.svgz |
||
55 | for size in $(ICON_SIZES); do \ |
||
56 | install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; \ |
||
57 | install -m644 pyscrabble-$$size.png \ |
||
58 | $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/pyscrabble.png; \ |
||
59 | done |
||
60 | install -d -m755 $(DESTDIR)/usr/share/applications/ |
||
61 | install -m644 debian/pyscrabble.desktop $(DESTDIR)/usr/share/applications/ |
||
62 | |||
63 | |||
64 | |||
65 | # Build architecture-dependent files here. |
||
66 | binary-arch: |
||
67 | # We have nothing to do by default. |
||
68 | |||
69 | # Build architecture-independent files here. |
||
70 | binary-indep: build install |
||
71 | dh_testdir |
||
72 | dh_testroot |
||
73 | dh_install --sourcedir=debian/tmp |
||
74 | dh_link |
||
38 | magnus | 75 | dh_python2 /usr/share/games/pyscrabble/python |
2 | magnus | 76 | dh_installchangelogs CHANGELOG.txt |
77 | dh_installdocs |
||
78 | dh_installexamples |
||
79 | dh_installman |
||
3 | magnus | 80 | dh_installinit -r |
2 | magnus | 81 | dh_installmenu |
82 | dh_strip |
||
83 | dh_compress |
||
84 | dh_fixperms |
||
85 | dh_installdeb |
||
86 | dh_shlibdeps |
||
87 | dh_gencontrol |
||
88 | dh_md5sums |
||
89 | dh_builddeb |
||
90 | |||
91 | binary: binary-indep binary-arch |
||
92 | .PHONY: build clean binary-indep binary-arch binary install configure |