Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Rev 19 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
DESTDIR=$(CURDIR)/debian/tmp
13
ICON_SIZES=16 22 32 48 64 96
14
PIXMAP_SIZES=16 32
15
 
16
include /usr/share/dpatch/dpatch.make
17
 
18
clean: clean-patched unpatch
19
	dh_clean
20
 
3 magnus 21
clean-patched: patch-stamp
2 magnus 22
	dh_testdir
23
	dh_testroot
3 magnus 24
	rm -f build-stamp
2 magnus 25
	rm -f pyscrabble-*.png pyscrabble-*.xpm
26
 
27
	python setup.py clean -a
28
	find -name '*.pyc' -delete
29
 
3 magnus 30
build: patch-stamp
2 magnus 31
	python setup.py build
32
 
33
	for size in $(ICON_SIZES); do \
34
		rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \
35
	done
36
	for size in $(PIXMAP_SIZES); do \
37
		convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \
38
	done
39
 
40
install: build
41
	dh_testdir
42
	dh_testroot
43
	dh_clean -k
44
 
45
	python setup.py install --no-compile --root=$(DESTDIR) \
46
		--install-scripts=/usr/games \
47
		--confdir=/etc/pyscrabble \
48
		--logdir=/var/log/pyscrabble \
49
		--dbdir=/var/lib/pyscrabble
18 magnus 50
	install -m755 -d $(DESTDIR)/usr/sbin
2 magnus 51
	mv $(DESTDIR)/usr/games/pyscrabble-main.py $(DESTDIR)/usr/games/pyscrabble
18 magnus 52
	mv $(DESTDIR)/usr/games/server_console.py $(DESTDIR)/usr/sbin/pyscrabble-server
2 magnus 53
#	rm $(DESTDIR)/usr/bin/db_upgrade.py
54
	install -m755 -d $(DESTDIR)/usr/share/pixmaps
55
	install -m644 pyscrabble-*.xpm $(DESTDIR)/usr/share/pixmaps
56
	install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/scalable/apps
57
	gzip < debian/pyscrabble.svg > $(DESTDIR)/usr/share/icons/hicolor/scalable/apps/pyscrabble.svgz
58
	for size in $(ICON_SIZES); do \
59
		install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; \
60
		install -m644 pyscrabble-$$size.png \
61
			$(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/pyscrabble.png; \
62
	done
63
	install -d -m755 $(DESTDIR)/usr/share/applications/
64
	install -m644 debian/pyscrabble.desktop $(DESTDIR)/usr/share/applications/
65
 
66
 
67
 
68
# Build architecture-dependent files here.
69
binary-arch:
70
# We have nothing to do by default.
71
 
72
# Build architecture-independent files here.
73
binary-indep: build install
74
	dh_testdir
75
	dh_testroot
76
	dh_install --sourcedir=debian/tmp
77
	dh_link
78
	dh_pycentral
79
	dh_installchangelogs CHANGELOG.txt
80
	dh_installdocs
81
	dh_installexamples
82
	dh_installman
3 magnus 83
	dh_installinit -r
2 magnus 84
	dh_installmenu
85
	dh_desktop
86
	dh_strip
87
	dh_compress
88
	dh_fixperms
89
	dh_installdeb
90
	dh_shlibdeps
91
	dh_gencontrol
92
	dh_md5sums
93
	dh_builddeb
94
 
95
binary: binary-indep binary-arch
96
.PHONY: build clean binary-indep binary-arch binary install configure