Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 20 | Rev 27 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
DESTDIR=$(CURDIR)/debian/tmp
13
ICON_SIZES=16 22 32 48 64 96
14
PIXMAP_SIZES=16 32
15
 
16
include /usr/share/dpatch/dpatch.make
17
 
23 magnus 18
unpatch: clean-patched
19
clean: unpatch
2 magnus 20
	dh_clean
21
 
3 magnus 22
clean-patched: patch-stamp
2 magnus 23
	dh_testdir
24
	dh_testroot
3 magnus 25
	rm -f build-stamp
2 magnus 26
	rm -f pyscrabble-*.png pyscrabble-*.xpm
27
 
28
	python setup.py clean -a
29
	find -name '*.pyc' -delete
30
 
23 magnus 31
build: build-stamp
32
build-stamp: patch-stamp
2 magnus 33
	python setup.py build
34
 
35
	for size in $(ICON_SIZES); do \
36
		rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \
37
	done
38
	for size in $(PIXMAP_SIZES); do \
39
		convert pyscrabble-$$size.png pyscrabble-$${size}x$${size}.xpm; \
40
	done
23 magnus 41
	touch "$@"
2 magnus 42
 
43
install: build
44
	dh_testdir
45
	dh_testroot
46
	dh_clean -k
47
 
48
	python setup.py install --no-compile --root=$(DESTDIR) \
19 magnus 49
		--prefix=/usr \
2 magnus 50
		--install-scripts=/usr/games \
51
		--confdir=/etc/pyscrabble \
52
		--logdir=/var/log/pyscrabble \
53
		--dbdir=/var/lib/pyscrabble
18 magnus 54
	install -m755 -d $(DESTDIR)/usr/sbin
2 magnus 55
	mv $(DESTDIR)/usr/games/pyscrabble-main.py $(DESTDIR)/usr/games/pyscrabble
18 magnus 56
	mv $(DESTDIR)/usr/games/server_console.py $(DESTDIR)/usr/sbin/pyscrabble-server
2 magnus 57
#	rm $(DESTDIR)/usr/bin/db_upgrade.py
58
	install -m755 -d $(DESTDIR)/usr/share/pixmaps
59
	install -m644 pyscrabble-*.xpm $(DESTDIR)/usr/share/pixmaps
60
	install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/scalable/apps
61
	gzip < debian/pyscrabble.svg > $(DESTDIR)/usr/share/icons/hicolor/scalable/apps/pyscrabble.svgz
62
	for size in $(ICON_SIZES); do \
63
		install -m755 -d $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; \
64
		install -m644 pyscrabble-$$size.png \
65
			$(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/pyscrabble.png; \
66
	done
67
	install -d -m755 $(DESTDIR)/usr/share/applications/
68
	install -m644 debian/pyscrabble.desktop $(DESTDIR)/usr/share/applications/
69
 
70
 
71
 
72
# Build architecture-dependent files here.
73
binary-arch:
74
# We have nothing to do by default.
75
 
76
# Build architecture-independent files here.
77
binary-indep: build install
78
	dh_testdir
79
	dh_testroot
80
	dh_install --sourcedir=debian/tmp
81
	dh_link
82
	dh_pycentral
83
	dh_installchangelogs CHANGELOG.txt
84
	dh_installdocs
85
	dh_installexamples
86
	dh_installman
3 magnus 87
	dh_installinit -r
2 magnus 88
	dh_installmenu
89
	dh_strip
90
	dh_compress
91
	dh_fixperms
92
	dh_installdeb
93
	dh_shlibdeps
94
	dh_gencontrol
95
	dh_md5sums
96
	dh_builddeb
97
 
98
binary: binary-indep binary-arch
99
.PHONY: build clean binary-indep binary-arch binary install configure