Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 23 | Rev 28 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 23 Rev 27
Line 11... Line 11...
11
11
12
DESTDIR=$(CURDIR)/debian/tmp
12
DESTDIR=$(CURDIR)/debian/tmp
13
ICON_SIZES=16 22 32 48 64 96
13
ICON_SIZES=16 22 32 48 64 96
14
PIXMAP_SIZES=16 32
14
PIXMAP_SIZES=16 32
15
15
16
include /usr/share/dpatch/dpatch.make
-
 
17
-
 
18
unpatch: clean-patched
-
 
19
clean: unpatch
-
 
20
	dh_clean
16
clean:
21
-
 
22
clean-patched: patch-stamp
-
 
23
	dh_testdir
17
	dh_testdir
24
	dh_testroot
18
	dh_testroot
25
	rm -f build-stamp
19
	rm -f build-stamp
26
	rm -f pyscrabble-*.png pyscrabble-*.xpm
20
	rm -f pyscrabble-*.png pyscrabble-*.xpm
27
21
28
	python setup.py clean -a
22
	python setup.py clean -a
29
	find -name '*.pyc' -delete
23
	find -name '*.pyc' -delete
-
 
24
	dh_clean
30
25
31
build: build-stamp
26
build: build-stamp
32
build-stamp: patch-stamp
27
build-stamp:
33
	python setup.py build
28
	python setup.py build
34
29
35
	for size in $(ICON_SIZES); do \
30
	for size in $(ICON_SIZES); do \
36
		rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \
31
		rsvg -h $$size -w $$size debian/pyscrabble.svg pyscrabble-$$size.png; \
37
	done
32
	done