Rev 1 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
1 | magnus | 1 | #!/usr/bin/make -f |
2 | # Sample debian/rules that uses debhelper. |
||
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
||
4 | |||
5 | # Uncomment this to turn on verbose mode. |
||
6 | #export DH_VERBOSE=1 |
||
7 | |||
8 | CFLAGS = -Wall -g |
||
9 | |||
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
||
11 | CFLAGS += -O0 |
||
12 | else |
||
13 | CFLAGS += -O2 |
||
14 | endif |
||
15 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
||
16 | INSTALL_PROGRAM += -s |
||
17 | endif |
||
18 | |||
19 | configure: configure-stamp |
||
20 | configure-stamp: |
||
21 | dh_testdir |
||
22 | touch configure-stamp |
||
23 | |||
24 | build: build-stamp |
||
25 | build-stamp: configure-stamp |
||
26 | dh_testdir |
||
27 | $(MAKE) LDFLAGS="-shared -fPIC" |
||
28 | touch build-stamp |
||
29 | |||
30 | clean: |
||
31 | dh_testdir |
||
32 | dh_testroot |
||
33 | rm -f build-stamp configure-stamp |
||
34 | -$(MAKE) clean |
||
35 | dh_clean |
||
36 | |||
37 | install: build |
||
38 | dh_testdir |
||
39 | dh_testroot |
||
40 | dh_clean -k |
||
41 | dh_installdirs |
||
42 | install -m755 sa-exim-*so \ |
||
43 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/sa-exim.so |
||
44 | install -m755 accept*so \ |
||
45 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/accept.so |
||
46 | sed "s/\/var\/spool\/exim/\/var\/spool\/sa-exim/" < sa-exim.conf > \ |
||
47 | $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
||
48 | chmod 644 $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
||
49 | install -m644 debian/15_sa-exim_plugin_path \ |
||
50 | $(CURDIR)/debian/sa-exim/etc/exim4/conf.d/main |
||
51 | install -m644 SA-greylisting-2.4x.diff \ |
||
52 | $(CURDIR)/debian/sa-exim/usr/share/doc/sa-exim/sa2.xpatches |
||
53 | install -m644 SA-greylisting-2.6.diff \ |
||
54 | $(CURDIR)/debian/sa-exim/usr/share/doc/sa-exim/sa2.xpatches |
||
55 | install -m644 Greylisting.pm \ |
||
56 | $(CURDIR)/debian/sa-exim/usr/share/perl5/Mail/SpamAssassin/Plugin/Greylisting.pm |
||
57 | install -m644 greylistclean.cron \ |
||
58 | $(CURDIR)/debian/sa-exim/etc/cron.d/greylistclean |
||
59 | install -m755 greylistclean \ |
||
60 | $(CURDIR)/debian/sa-exim/usr/sbin/greylistclean |
||
61 | |||
62 | # Build architecture-independent files here. |
||
63 | binary-indep: build install |
||
64 | # We have nothing to do by default. |
||
65 | |||
66 | # Build architecture-dependent files here. |
||
67 | binary-arch: build install |
||
68 | dh_testdir |
||
69 | dh_testroot |
||
70 | dh_installchangelogs Changelog.html |
||
71 | dh_installdocs |
||
72 | dh_installexamples |
||
73 | # dh_install |
||
74 | # dh_installmenu |
||
75 | dh_installdebconf |
||
76 | # dh_installlogrotate |
||
77 | # dh_installemacsen |
||
78 | # dh_installpam |
||
79 | # dh_installmime |
||
80 | # dh_installinit |
||
81 | # dh_installcron |
||
82 | # dh_installinfo |
||
83 | dh_installman |
||
84 | dh_link |
||
85 | dh_strip |
||
86 | dh_compress |
||
87 | dh_fixperms -Xvar/spool/sa-exim |
||
88 | # dh_perl |
||
89 | # dh_python |
||
90 | # dh_makeshlibs |
||
91 | dh_installdeb |
||
92 | dh_shlibdeps |
||
93 | dh_gencontrol |
||
94 | dh_md5sums |
||
95 | dh_builddeb |
||
96 | |||
97 | binary: binary-indep binary-arch |
||
98 | .PHONY: build clean binary-indep binary-arch binary install configure |