Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 68 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 68 Rev 73
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper.
2
# Sample debian/rules that uses debhelper.
3
# GNU copyright 1997 to 1999 by Joey Hess.
3
# GNU copyright 1997 to 1999 by Joey Hess.
4
4
5
# Uncomment this to turn on verbose mode.
5
# Uncomment this to turn on verbose mode.
6
#export DH_VERBOSE=1
6
#export DH_VERBOSE=1
7
7
8
CFLAGS = -Wall -g
8
CFLAGS = -Wall -g
9
9
10
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
10
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
11
	CFLAGS += -O0
11
	CFLAGS += -O0
12
else
12
else
13
	CFLAGS += -O2
13
	CFLAGS += -O2
14
endif
14
endif
15
15
16
build: build-arch
16
build: build-arch
17
17
18
build-indep:
18
build-indep:
19
19
20
build-arch: build-stamp
20
build-arch: build-stamp
21
build-stamp:
21
build-stamp:
22
	dh_testdir
22
	dh_testdir
23
	$(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' SUFF=''
23
	$(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' SUFF=''
24
	touch build-stamp
24
	touch build-stamp
25
25
26
clean:
26
clean:
27
	dh_testdir
27
	dh_testdir
28
	dh_testroot
28
	dh_testroot
29
	rm -f build-stamp
29
	rm -f build-stamp
30
	$(MAKE) clean
30
	$(MAKE) clean
31
	dh_clean
31
	dh_clean
32
32
33
# Build architecture-independent files here.
33
# Build architecture-independent files here.
34
binary-indep:
34
binary-indep:
35
# We have nothing to do by default.
35
# We have nothing to do by default.
36
36
37
# Build architecture-dependent files here.
37
# Build architecture-dependent files here.
38
binary-arch: build
38
binary-arch: build
39
	dh_testdir
39
	dh_testdir
40
	dh_testroot
40
	dh_testroot
41
	dh_prep
41
	dh_prep
42
	dh_install
42
	dh_install
43
	dh_installchangelogs Changelog.html
43
	dh_installchangelogs Changelog.html
44
	dh_installdocs
44
	dh_installdocs
45
	dh_installexamples
45
	dh_installexamples
46
	dh_installdebconf	
46
	dh_installdebconf	
47
	dh_installman
47
	dh_installman
48
	dh_installcron --name=greylistclean
48
	dh_installcron --name=greylistclean
49
	dh_lintian
49
	dh_lintian
50
	dh_link
50
	dh_link
51
	dh_strip
51
	dh_strip
52
	dh_compress
52
	dh_compress
53
	dh_fixperms
53
	dh_fixperms
54
	dh_perl
54
	dh_perl
55
	dh_installdeb
55
	dh_installdeb
56
	dh_shlibdeps
56
	dh_shlibdeps
57
	echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \
57
	echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \
58
	   >> debian/sa-exim.substvars
58
	   >> debian/sa-exim.substvars
59
	dh_gencontrol
59
	dh_gencontrol
60
	dh_md5sums
60
	dh_md5sums
61
	dh_builddeb
61
	dh_builddeb
62
62
63
binary: binary-indep binary-arch
63
binary: binary-indep binary-arch
64
.PHONY: build build-indep build-arch clean binary-indep binary-arch binary
64
.PHONY: build build-indep build-arch clean binary-indep binary-arch binary