Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 82 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 82 Rev 88
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper.
2
# Sample debian/rules that uses debhelper.
3
# GNU copyright 1997 to 1999 by Joey Hess.
3
# GNU copyright 1997 to 1999 by Joey Hess.
4
4
5
# Uncomment this to turn on verbose mode.
5
# Uncomment this to turn on verbose mode.
6
#export DH_VERBOSE=1
6
#export DH_VERBOSE=1
7
7
8
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
8
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
9
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
9
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
10
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
10
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
11
11
12
build: build-arch
12
build: build-arch
13
13
14
build-indep:
14
build-indep:
15
15
16
build-arch: build-stamp
16
build-arch: build-stamp
17
build-stamp:
17
build-stamp:
18
	dh_testdir
18
	dh_testdir
19
	$(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CPPFLAGS) $$(CFLAGS)' \
19
	$(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CPPFLAGS) $$(CFLAGS)' \
20
	  CPPFLAGS='$(CPPFLAGS)' CFLAGS='$(CFLAGS)' LDFLAGS='-shared $(LDFLAGS)' SUFF=''
20
	  CPPFLAGS='$(CPPFLAGS)' CFLAGS='$(CFLAGS)' LDFLAGS='-shared $(LDFLAGS)' SUFF=''
21
	touch build-stamp
21
	touch build-stamp
22
22
23
clean:
23
clean:
24
	dh_testdir
24
	dh_testdir
25
	dh_testroot
25
	dh_testroot
26
	rm -f build-stamp
26
	rm -f build-stamp
27
	$(MAKE) clean
27
	$(MAKE) clean
28
	dh_clean
28
	dh_clean
29
29
30
# Build architecture-independent files here.
30
# Build architecture-independent files here.
31
binary-indep:
31
binary-indep:
32
# We have nothing to do by default.
32
# We have nothing to do by default.
33
33
34
# Build architecture-dependent files here.
34
# Build architecture-dependent files here.
35
binary-arch: build
35
binary-arch: build
36
	dh_testdir
36
	dh_testdir
37
	dh_testroot
37
	dh_testroot
38
	dh_prep
38
	dh_prep
39
	dh_install
39
	dh_install
40
	dh_installchangelogs Changelog.html
40
	dh_installchangelogs Changelog.html
41
	dh_installdocs
41
	dh_installdocs
42
	dh_installexamples
42
	dh_installexamples
43
	dh_installdebconf	
43
	dh_installdebconf	
44
	dh_installman
44
	dh_installman
45
	dh_installcron --name=greylistclean
45
	dh_installcron --name=greylistclean
46
	dh_lintian
46
	dh_lintian
47
	dh_link
47
	dh_link
48
	dh_strip
48
	dh_strip
49
	dh_compress
49
	dh_compress
50
	dh_fixperms
50
	dh_fixperms
51
	dh_perl
51
	dh_perl
52
	dh_installdeb
52
	dh_installdeb
53
	dh_shlibdeps
53
	dh_shlibdeps
54
	echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \
54
	echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \
55
	   >> debian/sa-exim.substvars
55
	   >> debian/sa-exim.substvars
56
	dh_gencontrol
56
	dh_gencontrol
57
	dh_md5sums
57
	dh_md5sums
58
	dh_builddeb
58
	dh_builddeb
59
59
60
binary: binary-indep binary-arch
60
binary: binary-indep binary-arch
61
.PHONY: build build-indep build-arch clean binary-indep binary-arch binary
61
.PHONY: build build-indep build-arch clean binary-indep binary-arch binary