Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
70 | magnus | 1 | Description: Simplify the sender address so that senders using VERP, |
2 | SRS, etc. hopefully won't be greylisted each and every time |
||
3 | Author: Magnus Holmgren <holmgren@debian.org> |
||
4 | Bug-Debian: http://bugs.debian.org/347590 |
||
5 | |||
6 | --- sa-exim-4.2.1.orig/Greylisting.pm |
||
7 | +++ sa-exim-4.2.1/Greylisting.pm |
||
8 | @@ -160,6 +160,8 @@ sub greylisting |
||
9 | # work around bug in perl untaint in perl 5.8 |
||
10 | $envfrom=undef; |
||
11 | $envfrom=$tmpvar; |
||
12 | + $envfrom =~ s/^([a-z0-9._]*)[^@]*/$1/i; |
||
13 | + |
||
14 | $rcptto =~ tr/!#%()*+,-.0123456789:<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[]^_abcdefghijklmnopqrstuvwxyz{|}~/_/c; |
||
15 | $rcptto =~ /(.+)/; |
||
16 | $tmpvar = ($1 or ""); |