Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
81 | magnus | 1 | From: Chaskiel Grundman <cg2v@andrew.cmu.edu> |
2 | Subject: Prevent warnings during spamassassin --lint |
||
3 | Bug: https://bugs.debian.org/760860 |
||
4 | |||
5 | --- a/Greylisting.pm |
||
6 | +++ b/Greylisting.pm |
||
7 | @@ -65,6 +65,10 @@ sub greylisting |
||
8 | my $dontcheckscore; |
||
9 | my %option; |
||
10 | |||
11 | + if ($self->{main}->{lint_rules}) { |
||
12 | + Mail::SpamAssassin::Plugin::dbg("GREYLISTING: disabled while linting"); |
||
13 | + return 0; |
||
14 | + } |
||
15 | Mail::SpamAssassin::Plugin::dbg("GREYLISTING: called function"); |
||
16 | |||
17 | $optionhash =~ s/;/,/g; |