Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
104 | magnus | 1 | Description: Eliminate most compiler warnings |
2 | Changing the type of scantime and fulltime from time_t to int is |
||
3 | probably not only not a problem, but the right thing to do, as |
||
4 | they will contain time differences, not timestamps. |
||
5 | Bug-Debian: https://bugs.debian.org/943570 |
||
6 | |||
7 | --- a/sa-exim.c |
||
8 | +++ b/sa-exim.c |
||
9 | @@ -282,7 +282,7 @@ static int savemail(int readfd, off_t fd |
||
10 | |||
11 | if (SAEximDebug > 8) |
||
12 | { |
||
13 | - log_write(0, LOG_MAIN, "SA: Debug9: Archive body write starts: writing up to %d bytes in %d byte blocks", SAmaxarchivebody, sizeof(buffera)); |
||
14 | + log_write(0, LOG_MAIN, "SA: Debug9: Archive body write starts: writing up to %d bytes in %z byte blocks", SAmaxarchivebody, sizeof(buffera)); |
||
15 | } |
||
16 | |||
17 | towrite=SAmaxarchivebody; |
||
18 | @@ -539,8 +539,8 @@ int local_scan(volatile int fd, uschar * |
||
19 | time_t beforescan; |
||
20 | time_t afterscan; |
||
21 | time_t afterwait; |
||
22 | - time_t scantime=0; |
||
23 | - time_t fulltime=0; |
||
24 | + int scantime=0; |
||
25 | + int fulltime=0; |
||
26 | struct stat stbuf; |
||
27 | |||
28 | uschar *expand; |
||
29 | @@ -1197,7 +1197,7 @@ restart: |
||
30 | { |
||
31 | if (SAEximDebug > 5) |
||
32 | { |
||
33 | - log_write(0, LOG_MAIN, "SA: Debug6: spamc read got newline, end of headers", buffer); |
||
34 | + log_write(0, LOG_MAIN, "SA: Debug6: spamc read got newline, end of headers"); |
||
35 | } |
||
36 | goto exit; |
||
37 | } |
||
38 | @@ -1257,7 +1257,7 @@ restart: |
||
39 | { |
||
40 | if (SAEximDebug > 8) |
||
41 | { |
||
42 | - log_write(0, LOG_MAIN, "SA: Debug9: Read body from SA; line %d (read %d)", line, strlen(buffer)); |
||
43 | + log_write(0, LOG_MAIN, "SA: Debug9: Read body from SA; line %d (read %z)", line, strlen(buffer)); |
||
44 | } |
||
45 | |||
46 | stret=write(fd, buffer, strlen(buffer)); |