Rev 21 | Rev 45 | Go to most recent revision | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 21 | Rev 32 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # Sample debian/rules that uses debhelper. |
2 | # Sample debian/rules that uses debhelper. |
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | 4 | ||
5 | # Uncomment this to turn on verbose mode. |
5 | # Uncomment this to turn on verbose mode. |
6 | #export DH_VERBOSE=1 |
6 | #export DH_VERBOSE=1 |
7 | 7 | ||
8 | CFLAGS = -Wall -g |
8 | CFLAGS = -Wall -g |
9 | 9 | ||
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
11 | CFLAGS += -O0 |
11 | CFLAGS += -O0 |
12 | else |
12 | else |
13 | CFLAGS += -O2 |
13 | CFLAGS += -O2 |
14 | endif |
14 | endif |
15 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
15 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
16 | INSTALL_PROGRAM += -s |
16 | INSTALL_PROGRAM += -s |
17 | endif |
17 | endif |
18 | 18 | ||
19 | configure: configure-stamp |
19 | configure: configure-stamp |
20 | configure-stamp: |
20 | configure-stamp: |
21 | dh_testdir |
21 | dh_testdir |
22 | touch configure-stamp |
22 | touch configure-stamp |
23 | 23 | ||
24 | build: build-stamp |
24 | build: build-stamp |
25 | build-stamp: configure-stamp |
25 | build-stamp: configure-stamp |
26 | dh_testdir |
26 | dh_testdir |
27 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' |
27 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' |
28 | touch build-stamp |
28 | touch build-stamp |
29 | 29 | ||
30 | clean: |
30 | clean: |
31 | dh_testdir |
31 | dh_testdir |
32 | dh_testroot |
32 | dh_testroot |
33 | rm -f build-stamp configure-stamp |
33 | rm -f build-stamp configure-stamp |
34 | -$(MAKE) clean |
34 | -$(MAKE) clean |
35 | dh_clean |
35 | dh_clean |
36 | 36 | ||
37 | install: build |
37 | install: build |
38 | dh_testdir |
38 | dh_testdir |
39 | dh_testroot |
39 | dh_testroot |
40 | dh_clean -k |
40 | dh_clean -k |
41 | dh_installdirs |
41 | dh_installdirs |
42 | install -m755 sa-exim-*so \ |
42 | install -m755 sa-exim-*so \ |
43 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/sa-exim.so |
43 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/sa-exim.so |
44 | install -m755 accept*so \ |
44 | install -m755 accept*so \ |
45 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/accept.so |
45 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/accept.so |
46 | sed "s/\/var\/spool\/exim/\/var\/spool\/sa-exim/" < sa-exim.conf > \ |
46 | sed "s/\/var\/spool\/exim/\/var\/spool\/sa-exim/" < sa-exim.conf > \ |
47 | $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
47 | $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
48 | chmod 644 $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
48 | chmod 644 $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
49 | install -m644 debian/15_sa-exim_plugin_path \ |
49 | install -m644 debian/15_sa-exim_plugin_path \ |
50 | $(CURDIR)/debian/sa-exim/etc/exim4/conf.d/main |
50 | $(CURDIR)/debian/sa-exim/etc/exim4/conf.d/main |
51 | install -m644 SA-greylisting-2.4x.diff \ |
51 | install -m644 SA-greylisting-2.4x.diff \ |
52 | $(CURDIR)/debian/sa-exim/usr/share/doc/sa-exim/sa2.xpatches |
52 | $(CURDIR)/debian/sa-exim/usr/share/doc/sa-exim/sa2.xpatches |
53 | install -m644 SA-greylisting-2.6.diff \ |
53 | install -m644 SA-greylisting-2.6.diff \ |
54 | $(CURDIR)/debian/sa-exim/usr/share/doc/sa-exim/sa2.xpatches |
54 | $(CURDIR)/debian/sa-exim/usr/share/doc/sa-exim/sa2.xpatches |
55 | install -m644 Greylisting.pm \ |
55 | install -m644 Greylisting.pm \ |
56 | $(CURDIR)/debian/sa-exim/usr/share/perl5/Mail/SpamAssassin/Plugin/Greylisting.pm |
56 | $(CURDIR)/debian/sa-exim/usr/share/perl5/Mail/SpamAssassin/Plugin/Greylisting.pm |
57 | install -m644 greylistclean.cron \ |
57 | install -m644 greylistclean.cron \ |
58 | $(CURDIR)/debian/sa-exim/etc/cron.d/greylistclean |
58 | $(CURDIR)/debian/sa-exim/etc/cron.d/greylistclean |
59 | install -m755 greylistclean \ |
59 | install -m755 greylistclean \ |
60 | $(CURDIR)/debian/sa-exim/usr/share/sa-exim/greylistclean |
60 | $(CURDIR)/debian/sa-exim/usr/share/sa-exim/greylistclean |
61 | 61 | ||
62 | # Build architecture-independent files here. |
62 | # Build architecture-independent files here. |
63 | binary-indep: build install |
63 | binary-indep: build install |
64 | # We have nothing to do by default. |
64 | # We have nothing to do by default. |
65 | 65 | ||
66 | # Build architecture-dependent files here. |
66 | # Build architecture-dependent files here. |
67 | binary-arch: build install |
67 | binary-arch: build install |
68 | dh_testdir |
68 | dh_testdir |
69 | dh_testroot |
69 | dh_testroot |
70 | dh_installchangelogs Changelog.html |
70 | dh_installchangelogs Changelog.html |
71 | dh_installdocs |
71 | dh_installdocs |
72 | dh_installexamples |
72 | dh_installexamples |
73 | dh_installdebconf |
73 | dh_installdebconf |
74 | dh_installman |
74 | dh_installman |
75 | dh_link |
75 | dh_link |
76 | dh_strip |
76 | dh_strip |
77 | dh_compress |
77 | dh_compress |
78 | dh_fixperms -Xvar/spool/sa-exim |
78 | dh_fixperms -Xvar/spool/sa-exim |
79 | dh_perl |
79 | dh_perl |
80 | dh_installdeb |
80 | dh_installdeb |
81 | dh_shlibdeps |
81 | dh_shlibdeps |
- | 82 | echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \ |
|
- | 83 | >> debian/sa-exim.substvars |
|
82 | dh_gencontrol |
84 | dh_gencontrol |
83 | dh_md5sums |
85 | dh_md5sums |
84 | dh_builddeb |
86 | dh_builddeb |
85 | 87 | ||
86 | binary: binary-indep binary-arch |
88 | binary: binary-indep binary-arch |
87 | .PHONY: build clean binary-indep binary-arch binary install configure |
89 | .PHONY: build clean binary-indep binary-arch binary install configure |