Rev 48 | Rev 65 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 48 | Rev 58 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # Sample debian/rules that uses debhelper. |
2 | # Sample debian/rules that uses debhelper. |
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | 4 | ||
5 | # Uncomment this to turn on verbose mode. |
5 | # Uncomment this to turn on verbose mode. |
6 | #export DH_VERBOSE=1 |
6 | #export DH_VERBOSE=1 |
7 | 7 | ||
8 | CFLAGS = -Wall -g |
8 | CFLAGS = -Wall -g |
9 | 9 | ||
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
11 | CFLAGS += -O0 |
11 | CFLAGS += -O0 |
12 | else |
12 | else |
13 | CFLAGS += -O2 |
13 | CFLAGS += -O2 |
14 | endif |
14 | endif |
15 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
15 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
16 | INSTALL_PROGRAM += -s |
16 | INSTALL_PROGRAM += -s |
17 | endif |
17 | endif |
18 | 18 | ||
19 | configure: configure-stamp |
19 | configure: configure-stamp |
20 | configure-stamp: |
20 | configure-stamp: |
21 | dh_testdir |
21 | dh_testdir |
22 | touch configure-stamp |
22 | touch configure-stamp |
23 | 23 | ||
24 | build: build-stamp |
24 | build: build-stamp |
25 | build-stamp: configure-stamp |
25 | build-stamp: configure-stamp |
26 | dh_testdir |
26 | dh_testdir |
27 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' |
27 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' |
28 | touch build-stamp |
28 | touch build-stamp |
29 | 29 | ||
30 | clean: |
30 | clean: |
31 | dh_testdir |
31 | dh_testdir |
32 | dh_testroot |
32 | dh_testroot |
33 | rm -f build-stamp configure-stamp |
33 | rm -f build-stamp configure-stamp |
34 | $(MAKE) clean |
34 | $(MAKE) clean |
35 | dh_clean |
35 | dh_clean |
36 | 36 | ||
37 | install: build |
37 | install: build |
38 | dh_testdir |
38 | dh_testdir |
39 | dh_testroot |
39 | dh_testroot |
40 | dh_clean -k |
40 | dh_clean -k |
41 | dh_installdirs |
41 | dh_installdirs |
42 | install -m755 sa-exim-*so \ |
42 | install -m755 sa-exim-*so \ |
43 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/sa-exim.so |
43 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/sa-exim.so |
44 | install -m755 accept*so \ |
44 | install -m755 accept*so \ |
45 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/accept.so |
45 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/accept.so |
46 | sed "s/\/var\/spool\/exim/\/var\/spool\/sa-exim/" < sa-exim.conf > \ |
46 | sed "s/\/var\/spool\/exim/\/var\/spool\/sa-exim/" < sa-exim.conf > \ |
47 | $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
47 | $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
48 | chmod 644 $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
48 | chmod 644 $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
49 | install -m644 debian/15_sa-exim_plugin_path \ |
49 | install -m644 debian/15_sa-exim_plugin_path \ |
50 | $(CURDIR)/debian/sa-exim/etc/exim4/conf.d/main |
50 | $(CURDIR)/debian/sa-exim/etc/exim4/conf.d/main |
51 | install -m644 Greylisting.pm \ |
51 | install -m644 Greylisting.pm \ |
52 | $(CURDIR)/debian/sa-exim/usr/share/perl5/Mail/SpamAssassin/Plugin/Greylisting.pm |
52 | $(CURDIR)/debian/sa-exim/usr/share/perl5/Mail/SpamAssassin/Plugin/Greylisting.pm |
53 | install -m644 greylistclean.cron \ |
53 | install -m644 greylistclean.cron \ |
54 | $(CURDIR)/debian/sa-exim/etc/cron.d/greylistclean |
54 | $(CURDIR)/debian/sa-exim/etc/cron.d/greylistclean |
55 | install -m755 greylistclean \ |
55 | install -m755 greylistclean \ |
56 | $(CURDIR)/debian/sa-exim/usr/share/sa-exim/greylistclean |
56 | $(CURDIR)/debian/sa-exim/usr/share/sa-exim/greylistclean |
57 | 57 | ||
58 | # Build architecture-independent files here. |
58 | # Build architecture-independent files here. |
59 | binary-indep: build install |
59 | binary-indep: build install |
60 | # We have nothing to do by default. |
60 | # We have nothing to do by default. |
61 | 61 | ||
62 | # Build architecture-dependent files here. |
62 | # Build architecture-dependent files here. |
63 | binary-arch: build install |
63 | binary-arch: build install |
64 | dh_testdir |
64 | dh_testdir |
65 | dh_testroot |
65 | dh_testroot |
66 | dh_installchangelogs Changelog.html |
66 | dh_installchangelogs Changelog.html |
67 | dh_installdocs |
67 | dh_installdocs |
68 | dh_installexamples |
68 | dh_installexamples |
69 | dh_installdebconf |
69 | dh_installdebconf |
70 | dh_installman |
70 | dh_installman |
- | 71 | install -d debian/sa-exim/usr/share/lintian/overrides |
|
- | 72 | install -m 644 debian/sa-exim.lintian-overrides \ |
|
- | 73 | debian/sa-exim/usr/share/lintian/overrides/sa-exim |
|
71 | dh_link |
74 | dh_link |
72 | dh_strip |
75 | dh_strip |
73 | dh_compress |
76 | dh_compress |
74 | dh_fixperms -Xvar/spool/sa-exim |
77 | dh_fixperms -Xvar/spool/sa-exim |
75 | dh_perl |
78 | dh_perl |
76 | dh_installdeb |
79 | dh_installdeb |
77 | dh_shlibdeps |
80 | dh_shlibdeps |
78 | echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \ |
81 | echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \ |
79 | >> debian/sa-exim.substvars |
82 | >> debian/sa-exim.substvars |
80 | dh_gencontrol |
83 | dh_gencontrol |
81 | dh_md5sums |
84 | dh_md5sums |
82 | dh_builddeb |
85 | dh_builddeb |
83 | 86 | ||
84 | binary: binary-indep binary-arch |
87 | binary: binary-indep binary-arch |
85 | .PHONY: build clean binary-indep binary-arch binary install configure |
88 | .PHONY: build clean binary-indep binary-arch binary install configure |