Rev 82 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
1 | magnus | 1 | #!/usr/bin/make -f |
2 | # Sample debian/rules that uses debhelper. |
||
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
||
4 | |||
5 | # Uncomment this to turn on verbose mode. |
||
6 | #export DH_VERBOSE=1 |
||
7 | |||
82 | magnus | 8 | CFLAGS := $(shell dpkg-buildflags --get CFLAGS) |
9 | CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS) |
||
10 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
||
1 | magnus | 11 | |
68 | magnus | 12 | build: build-arch |
1 | magnus | 13 | |
68 | magnus | 14 | build-indep: |
15 | |||
16 | build-arch: build-stamp |
||
17 | build-stamp: |
||
1 | magnus | 18 | dh_testdir |
93 | magnus | 19 | $(MAKE) BUILDCFLAGS='-DLOCAL_SCAN -I/usr/include/exim4 -fPIC $$(CPPFLAGS) $$(CFLAGS)' \ |
82 | magnus | 20 | CPPFLAGS='$(CPPFLAGS)' CFLAGS='$(CFLAGS)' LDFLAGS='-shared $(LDFLAGS)' SUFF='' |
1 | magnus | 21 | touch build-stamp |
22 | |||
23 | clean: |
||
24 | dh_testdir |
||
25 | dh_testroot |
||
68 | magnus | 26 | rm -f build-stamp |
45 | magnus | 27 | $(MAKE) clean |
1 | magnus | 28 | dh_clean |
29 | |||
30 | # Build architecture-independent files here. |
||
68 | magnus | 31 | binary-indep: |
1 | magnus | 32 | # We have nothing to do by default. |
33 | |||
34 | # Build architecture-dependent files here. |
||
68 | magnus | 35 | binary-arch: build |
1 | magnus | 36 | dh_testdir |
37 | dh_testroot |
||
68 | magnus | 38 | dh_prep |
39 | dh_install |
||
1 | magnus | 40 | dh_installchangelogs Changelog.html |
41 | dh_installdocs |
||
42 | dh_installexamples |
||
43 | dh_installdebconf |
||
44 | dh_installman |
||
68 | magnus | 45 | dh_installcron --name=greylistclean |
46 | dh_lintian |
||
1 | magnus | 47 | dh_link |
48 | dh_strip |
||
49 | dh_compress |
||
65 | magnus | 50 | dh_fixperms |
6 | magnus | 51 | dh_perl |
1 | magnus | 52 | dh_installdeb |
53 | dh_shlibdeps |
||
32 | magnus | 54 | echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \ |
55 | >> debian/sa-exim.substvars |
||
1 | magnus | 56 | dh_gencontrol |
57 | dh_md5sums |
||
58 | dh_builddeb |
||
59 | |||
60 | binary: binary-indep binary-arch |
||
68 | magnus | 61 | .PHONY: build build-indep build-arch clean binary-indep binary-arch binary |