Rev 65 | Rev 82 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
1 | magnus | 1 | #!/usr/bin/make -f |
2 | # Sample debian/rules that uses debhelper. |
||
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
||
4 | |||
5 | # Uncomment this to turn on verbose mode. |
||
6 | #export DH_VERBOSE=1 |
||
7 | |||
8 | CFLAGS = -Wall -g |
||
9 | |||
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
||
11 | CFLAGS += -O0 |
||
12 | else |
||
13 | CFLAGS += -O2 |
||
14 | endif |
||
15 | |||
68 | magnus | 16 | build: build-arch |
1 | magnus | 17 | |
68 | magnus | 18 | build-indep: |
19 | |||
20 | build-arch: build-stamp |
||
21 | build-stamp: |
||
1 | magnus | 22 | dh_testdir |
68 | magnus | 23 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' SUFF='' |
1 | magnus | 24 | touch build-stamp |
25 | |||
26 | clean: |
||
27 | dh_testdir |
||
28 | dh_testroot |
||
68 | magnus | 29 | rm -f build-stamp |
45 | magnus | 30 | $(MAKE) clean |
1 | magnus | 31 | dh_clean |
32 | |||
33 | # Build architecture-independent files here. |
||
68 | magnus | 34 | binary-indep: |
1 | magnus | 35 | # We have nothing to do by default. |
36 | |||
37 | # Build architecture-dependent files here. |
||
68 | magnus | 38 | binary-arch: build |
1 | magnus | 39 | dh_testdir |
40 | dh_testroot |
||
68 | magnus | 41 | dh_prep |
42 | dh_install |
||
1 | magnus | 43 | dh_installchangelogs Changelog.html |
44 | dh_installdocs |
||
45 | dh_installexamples |
||
46 | dh_installdebconf |
||
47 | dh_installman |
||
68 | magnus | 48 | dh_installcron --name=greylistclean |
49 | dh_lintian |
||
1 | magnus | 50 | dh_link |
51 | dh_strip |
||
52 | dh_compress |
||
65 | magnus | 53 | dh_fixperms |
6 | magnus | 54 | dh_perl |
1 | magnus | 55 | dh_installdeb |
56 | dh_shlibdeps |
||
32 | magnus | 57 | echo "exim:Depends=exim4-localscanapi-`exim4-localscan-plugin-config --localscan-apiversion`" \ |
58 | >> debian/sa-exim.substvars |
||
1 | magnus | 59 | dh_gencontrol |
60 | dh_md5sums |
||
61 | dh_builddeb |
||
62 | |||
63 | binary: binary-indep binary-arch |
||
68 | magnus | 64 | .PHONY: build build-indep build-arch clean binary-indep binary-arch binary |