Rev 65 | Rev 82 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 65 | Rev 68 | ||
---|---|---|---|
Line 11... | Line 11... | ||
11 | CFLAGS += -O0 |
11 | CFLAGS += -O0 |
12 | else |
12 | else |
13 | CFLAGS += -O2 |
13 | CFLAGS += -O2 |
14 | endif |
14 | endif |
15 | 15 | ||
16 | configure: configure-stamp |
16 | build: build-arch |
- | 17 | ||
17 | configure-stamp: |
18 | build-indep: |
18 | dh_testdir |
- | |
19 | touch configure-stamp |
- | |
20 | 19 | ||
21 | build: build-stamp |
20 | build-arch: build-stamp |
22 | build-stamp: configure-stamp |
21 | build-stamp: |
23 | dh_testdir |
22 | dh_testdir |
24 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' |
23 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' SUFF='' |
25 | touch build-stamp |
24 | touch build-stamp |
26 | 25 | ||
27 | clean: |
26 | clean: |
28 | dh_testdir |
27 | dh_testdir |
29 | dh_testroot |
28 | dh_testroot |
30 | rm -f build-stamp configure-stamp |
29 | rm -f build-stamp |
31 | $(MAKE) clean |
30 | $(MAKE) clean |
32 | dh_clean |
31 | dh_clean |
33 | 32 | ||
34 | install: build |
- | |
35 | dh_testdir |
- | |
36 | dh_testroot |
- | |
37 | dh_clean -k |
- | |
38 | dh_installdirs |
- | |
39 | install -m755 sa-exim-*so \ |
- | |
40 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/sa-exim.so |
- | |
41 | install -m755 accept*so \ |
- | |
42 | $(CURDIR)/debian/sa-exim/usr/lib/exim4/local_scan/accept.so |
- | |
43 | sed "s/\/var\/spool\/exim/\/var\/spool\/sa-exim/" < sa-exim.conf > \ |
- | |
44 | $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
- | |
45 | chmod 644 $(CURDIR)/debian/sa-exim/etc/exim4/sa-exim.conf |
- | |
46 | install -m644 debian/15_sa-exim_plugin_path \ |
- | |
47 | $(CURDIR)/debian/sa-exim/etc/exim4/conf.d/main |
- | |
48 | install -m644 Greylisting.pm \ |
- | |
49 | $(CURDIR)/debian/sa-exim/usr/share/perl5/Mail/SpamAssassin/Plugin/Greylisting.pm |
- | |
50 | install -m644 greylistclean.cron \ |
- | |
51 | $(CURDIR)/debian/sa-exim/etc/cron.d/greylistclean |
- | |
52 | install -m755 greylistclean \ |
- | |
53 | $(CURDIR)/debian/sa-exim/usr/share/sa-exim/greylistclean |
- | |
54 | - | ||
55 | # Build architecture-independent files here. |
33 | # Build architecture-independent files here. |
56 | binary-indep: build install |
34 | binary-indep: |
57 | # We have nothing to do by default. |
35 | # We have nothing to do by default. |
58 | 36 | ||
59 | # Build architecture-dependent files here. |
37 | # Build architecture-dependent files here. |
60 | binary-arch: build install |
38 | binary-arch: build |
61 | dh_testdir |
39 | dh_testdir |
62 | dh_testroot |
40 | dh_testroot |
- | 41 | dh_prep |
|
- | 42 | dh_install |
|
63 | dh_installchangelogs Changelog.html |
43 | dh_installchangelogs Changelog.html |
64 | dh_installdocs |
44 | dh_installdocs |
65 | dh_installexamples |
45 | dh_installexamples |
66 | dh_installdebconf |
46 | dh_installdebconf |
67 | dh_installman |
47 | dh_installman |
68 | install -d debian/sa-exim/usr/share/lintian/overrides |
48 | dh_installcron --name=greylistclean |
69 | install -m 644 debian/sa-exim.lintian-overrides \ |
49 | dh_lintian |
70 | debian/sa-exim/usr/share/lintian/overrides/sa-exim |
- | |
71 | dh_link |
50 | dh_link |
72 | dh_strip |
51 | dh_strip |
73 | dh_compress |
52 | dh_compress |
74 | dh_fixperms |
53 | dh_fixperms |
75 | dh_perl |
54 | dh_perl |
Line 80... | Line 59... | ||
80 | dh_gencontrol |
59 | dh_gencontrol |
81 | dh_md5sums |
60 | dh_md5sums |
82 | dh_builddeb |
61 | dh_builddeb |
83 | 62 | ||
84 | binary: binary-indep binary-arch |
63 | binary: binary-indep binary-arch |
85 | .PHONY: build clean binary-indep binary-arch binary install configure |
64 | .PHONY: build build-indep build-arch clean binary-indep binary-arch binary |