Rev 68 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 68 | Rev 82 | ||
---|---|---|---|
Line 3... | Line 3... | ||
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
3 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | 4 | ||
5 | # Uncomment this to turn on verbose mode. |
5 | # Uncomment this to turn on verbose mode. |
6 | #export DH_VERBOSE=1 |
6 | #export DH_VERBOSE=1 |
7 | 7 | ||
8 | CFLAGS = -Wall -g |
8 | CFLAGS := $(shell dpkg-buildflags --get CFLAGS) |
9 | - | ||
10 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
9 | CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS) |
11 | CFLAGS += -O0 |
- | |
12 | else |
- | |
13 | CFLAGS += -O2 |
10 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
14 | endif |
- | |
15 | 11 | ||
16 | build: build-arch |
12 | build: build-arch |
17 | 13 | ||
18 | build-indep: |
14 | build-indep: |
19 | 15 | ||
20 | build-arch: build-stamp |
16 | build-arch: build-stamp |
21 | build-stamp: |
17 | build-stamp: |
22 | dh_testdir |
18 | dh_testdir |
23 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CFLAGS)' SUFF='' |
19 | $(MAKE) BUILDCFLAGS='-I/usr/include/exim4 -fPIC $$(CPPFLAGS) $$(CFLAGS)' \ |
- | 20 | CPPFLAGS='$(CPPFLAGS)' CFLAGS='$(CFLAGS)' LDFLAGS='-shared $(LDFLAGS)' SUFF='' |
|
24 | touch build-stamp |
21 | touch build-stamp |
25 | 22 | ||
26 | clean: |
23 | clean: |
27 | dh_testdir |
24 | dh_testdir |
28 | dh_testroot |
25 | dh_testroot |