Subversion Repositories sa-exim

Compare Revisions

Ignore whitespace Rev 90 → Rev 91

/trunk/debian/patches/api-limitations.patch
30,8 → 30,22
/* New values we read from spamassassin */
char *xspamstatus=NULL;
char *xspamflag=NULL;
@@ -1241,6 +1242,7 @@ restart:
@@ -1229,18 +1230,20 @@ restart:
}
}
+
if (SAEximDebug > 1)
{
log_write(0, LOG_MAIN, "SA: Debug2: body_linecount before SA: %d", body_linecount);
}
/* update global variable $body_linecount to reflect the new body size*/
- body_linecount = (line - 1);
+ if (body_linecount > 0) body_linecount = (line - 1); // Not updating if zero, indicating spool_wireformat
if (SAEximDebug > 1)
{
log_write(0, LOG_MAIN, "SA: Debug2: body_linecount after SA: %d", body_linecount);
}
+
38,7 → 52,7
}
fclose((FILE *)readfh);
@@ -1331,6 +1333,9 @@ restart:
@@ -1331,6 +1334,9 @@ restart:
if (dorej && doteergrube)
{
48,7 → 62,7
/* By default, we'll only save temp bounces by message ID so
* that when the same message is submitted several times, we
* overwrite the same file on disk and not create a brand new
@@ -1353,20 +1358,8 @@ restart:
@@ -1353,20 +1359,8 @@ restart:
for (i=0;i<SAteergrubetime/10;i++)
{