Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 37 | Blame | Compare with Previous | Last modification | View Log | RSS feed

Author: Magnus Holmgren <holmgren@debian.org>
Description: Pass CFLAGS and LDFLAGS to xmkmf-generated Makefiles
 Pass CFLAGS and LDFLAGS through via ./Makefile as
 CDEBUGFLAGS and LOCAL_LDFLAGS to vnc_unixsrc/*/Makefile

--- a/Makefile
+++ b/Makefile
@@ -53,8 +53,8 @@ config:
        @echo Now run: "'make all'"
 
 all:
-       cd $(VSRC)/libvncauth; $(MAKE)
-       cd $(VSRC)/vncviewer;  $(MAKE)
+       cd $(VSRC)/libvncauth; $(MAKE) EXTRA_DEFINES="$(CPPFLAGS)" CDEBUGFLAGS="$(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)"
+       cd $(VSRC)/vncviewer;  $(MAKE) EXTRA_DEFINES="$(CPPFLAGS)" CDEBUGFLAGS="$(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)"
        if [ "X$(JSRC)" != "X" ]; then cd $(JSRC); $(MAKE); fi
        cd $(PSRC); $(MAKE)