Subversion Repositories

?revision_form?
Rev ?revision_input??revision_submit?
?revision_endform?

Show changed files | Details | Compare with Previous | Blame | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
57 486d 08h magnus /ssvnc/trunk/debian/ Bump Standards-Version to 4.4.1.  
56 486d 08h magnus /ssvnc/trunk/debian/ * Porting of libvncclient security patches by the jessie LTS team
(Closes: #945827):
- CVE-2018-20020: heap out-of-bound write vulnerability inside structure
in VNC client code.
- CVE-2018-20021: CWE-835: Infinite loop vulnerability in VNC client code.
- CVE-2018-20022: CWE-665: Improper Initialization vulnerability.
- CVE-2018-20024: null pointer dereference that can result DoS.
 
53 1026d 09h magnus /ssvnc/trunk/debian/ Switch to Debhelper compat level 10.  
52 1026d 10h magnus /ssvnc/trunk/debian/ Replace priority extra with optional.  
50 1026d 10h magnus /ssvnc/trunk/debian/ default-jdk-headless is enough to build.  
48 1720d 06h magnus /ssvnc/trunk/debian/ Bump Standards-Version to 3.9.8.  
39 1720d 17h magnus /ssvnc/trunk/debian/ debian/rules: Add call to dh_strip_nondeterminism.  
35 3444d 06h magnus /ssvnc/trunk/debian/ Bump Standards-Version to 3.9.2.  
31 3444d 07h magnus /ssvnc/trunk/debian/ Get CFLAGS and LDFLAGS from dpkg-buildflags.  
27 3476d 06h magnus /ssvnc/trunk/debian/ Simply build-depend on libjpeg-dev instead of libjpeg62-dev |
libjpeg-dev (Closes: #644808).
 
22 3721d 05h magnus /ssvnc/trunk/debian/ Up Standards-Version to 3.9.1.  
21 3721d 05h magnus /ssvnc/trunk/debian/ Remove redundant bash dependency; bash isn't going to be non-essential
any time soon.
 
19 3721d 07h magnus /ssvnc/trunk/debian/ Convert to source format 3.0 (quilt), changing /bin/sh into /bin/bash
(see below) in the install target instead.
 
16 3980d 10h magnus /ssvnc/trunk/debian/ bashisms.dpatch: Don't try to fix all bashisms; instead change /bin/sh
to /bin/bash and depend on bash, which is small in this context.
 
11 4184d 07h magnus /ssvnc/trunk/debian/ exception has been granted. Build-depend on libssl-dev.  
10 4184d 07h magnus /ssvnc/trunk/debian/ * Add README.source.
* Bump Standards-Version to 3.8.3.
 
9 4184d 08h magnus /ssvnc/trunk/debian/ Promote stunnel4 from Recommends to Depends (Closes: #553411), depend
directly on openssl, depend on tk instead of tk8.4, and tweak java
recommendations.
 
3 4184d 14h magnus /ssvnc/trunk/debian/ [svn-inject] Applying Debian modifications to trunk