Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 14 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#!/bin/sh -e
## bashisms.dpatch by Magnus Holmgren <holmgren@debian.org>
##
## DP: Change all shell references to /bin/bash to avoid problems
## DP: when /bin/sh is not Bash.

dpatch_patch() {
    files=`grep -Rl '/bin/sh' scripts`

    if [ ! -f debian/patched/patched-bashisms.tar.gz ]; then
        tar -czf debian/patched/patched-bashisms.tar.gz $files
        sed -ri -e 's#/bin/sh#/bin/bash#g' $files
    fi
}

dpatch_unpatch() {
    # Change line endings back to CRLF in files that had it in the tarball
    tar -xzf debian/patched/patched-bashisms.tar.gz
}

DPATCH_LIB_NO_DEFAULT=1

. /usr/share/dpatch/dpatch.lib.sh