Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 4 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 4 Rev 14
Line 2... Line 2...
2
## confusing_-h.dpatch by  <holmgren@debian.org>
2
## confusing_-h.dpatch by  <holmgren@debian.org>
3
##
3
##
4
## DP: Improve handling of -h[e[l[p]]]
4
## DP: Improve handling of -h[e[l[p]]]
5
5
6
@DPATCH@
6
@DPATCH@
7
diff -urNad trunk~/scripts/sshvnc trunk/scripts/sshvnc
-
 
8
--- trunk~/scripts/sshvnc	2007-08-24 03:24:14.000000000 +0200
-
 
9
+++ trunk/scripts/sshvnc	2009-10-31 16:14:11.000000000 +0100
-
 
10
@@ -4,4 +4,4 @@
-
 
11
 # 
-
 
12
 PATH=`dirname "$0"`:$PATH; export PATH
-
 
13
 SSVNC_SSH_ONLY=1; export SSVNC_SSH_ONLY
-
 
14
-exec ssvnc -ssh "$@"
-
 
15
+exec ssvnc "$@"
-
 
16
diff -urNad trunk~/scripts/ssvnc trunk/scripts/ssvnc
7
diff -urNad trunk~/scripts/ssvnc trunk/scripts/ssvnc
17
--- trunk~/scripts/ssvnc	2009-10-25 15:15:48.000000000 +0100
8
--- trunk~/scripts/ssvnc	2009-12-27 21:38:58.000000000 +0100
18
+++ trunk/scripts/ssvnc	2009-10-31 16:04:48.000000000 +0100
9
+++ trunk/scripts/ssvnc	2010-02-06 20:38:41.000000000 +0100
19
@@ -8,7 +8,8 @@
10
@@ -8,7 +8,8 @@
20
 #
11
 #
21
 # See ssvnc_cmd for details.
12
 # See ssvnc_cmd for details.
22
 #
13
 #
23
-if [ "X$1" = "X-help" -o "X$1" = "X-h" ]; then
14
-if [ "X$1" = "X-help" -o "X$1" = "X-h" ]; then
24
+helpflag="-help"
15
+helpflag="-help"
25
+if [ ${#1} -gt 1 -a "$1${helpflag##$1}" = $helpflag ]; then
16
+if [ ${#1} -gt 1 -a "$1${helpflag##$1}" = $helpflag ]; then
26
 	cat << END
17
 	cat << END
27
 ssvnc - a GUI wrapper for SSL and SSH VNC connections.
18
 ssvnc - a GUI wrapper for SSL and SSH VNC connections.
28
 
19
 
-
 
20
@@ -106,7 +107,7 @@
-
 
21
 	exit 0
-
 
22
 fi
-
 
23
 if [ "X$1" = "X-ssh" ]; then
29
diff -urNad trunk~/scripts/tsvnc trunk/scripts/tsvnc
24
-	if [ "X$2" = "X-help" -o "X$2" = "X-h" ]; then
30
--- trunk~/scripts/tsvnc	2007-08-24 18:18:12.000000000 +0200
25
+	if [ ${#2} -gt 1 -a "$2${helpflag##$2}" = $helpflag ]; then
-
 
26
 		cat << END
31
+++ trunk/scripts/tsvnc	2009-10-31 16:13:45.000000000 +0100
27
 sshvnc - a GUI wrapper for SSH VNC connections.
-
 
28
 
32
@@ -4,4 +4,4 @@
29
@@ -124,7 +125,7 @@
33
 # 
30
 fi
-
 
31
 
34
 PATH=`dirname "$0"`:$PATH; export PATH
32
 if [ "X$1" = "X-ts" -o "X$1" = "X-tso" ]; then
35
 SSVNC_TS_ONLY=1; export SSVNC_TS_ONLY
33
-	if [ "X$2" = "X-help" -o "X$2" = "X-h" ]; then
36
-exec ssvnc -ts "$@"
34
+	if [ ${#2} -gt 1 -a "$2${helpflag##$2}" = $helpflag ]; then
37
+exec ssvnc "$@"
35
 		cat << END
-
 
36
 tsvnc - a GUI wrapper for SSH VNC connections using x11vnc Terminal Services.
-
 
37